информатика

Главная

Учебник :
Глава 1
Глава 2
Глава 3
Глава 4
Глава 5
Глава 6

Тест
Проверь себя

  1. Какие существуют правила преобразования логических выражений?

  2. Какие законы логики вы знаете?


Учебник

Струкова Наталья Федоровна, учитель математики и информатики МБОУ СОШ № 13, г. Златоуст, Челябинская область


Оглавление

Нижняя часть


Created using
htm2chm 3.0

Download it NOW!


Какой сигнал получится на выходе схемы (в точке E)

Карточка № 1 Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0001

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0002

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0003

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0004

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0005

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0006

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0007

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0008

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0009

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0010

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0011

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0012

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0013

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0014

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0015

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0016

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |


Введение

Как работать с электронным пособием

В пособие включены теоретические материалы, практические и контрольные работы для закрепления и проверки знаний, а также словарь основных понятий и терминов , которые встречаются в пособии.

В первую очередь советую Вам разобраться с теорией, затем выполнить практические задания. Свои результаты можете проверить в пункте ответы Если ответ не получился, можно посмотреть решение и попробовать найти ошибку. После успешного выполнения практических заданий попробуйте выполнить задания из контрольной работы, в конце которой есть кнопка "Посмотреть результат", нажав на которую вы получите рекомендуемую оценку. После успешного усвоения материала вы можете приступить к изучению следующего раздела.

Пособие обладает значками- ориентирами, которые Вам помогут не заблудиться в электронном пособии, а также Вам помогут в навигации по книге.
Значки и пояснения к ним.


  • Введение
    • Введение
    • Немного истории
    • Формы мышления
      • Формы мышления
      • Пройди тест
      • Практика
      • Ответы
      • С.р. Вариант I
      • С.р. Вариант II
      • Контрольный тест
    • Логические операции
      • Логические операции
      • Тест № 1
      • Практика
      • Таблицы истинности
      • Практика
      • Ответы
      • Обучающий тест
      • Сам. работа 1
      • Сам. работа 2
    • Законы логики
      • Логические законы
      • Практика
      • Практика
      • 14. Название страницы
      • Контроль
    • Логические схемы
      • Логические операции
      • Практика
      • Задачи
      • Ответы
      • Сам. работа 1.
      • Сам. работа 2.
    • Решение логических задач
      • Табличным способом
      • С помощью рассуждений
      • С помощью графов
      • С помощью диаграмм

        Эйлера-Венна
      • Практика
      • Решить самостоятельно
    • Логические устройства ПК
      • Логические элементы ПК
      • Мини плакаты
      • Динамические модели
        логических элементов
      • Решение задач
      • Решение задач


Немного истории

Аристотель (384г.-322г.до н.э.) | Вильгельм Лейбниц (1646-1716) | Джордж Буль (1815-1864) | Клод Шеннон (1916-2001г)

В основе работы логических схем и устройств персонального компьютера лежит специальный математический аппарат - математическая логика. Математическая логика изучает вопросы применения математических методов для решения логических задач и построения логических схем. Знание логики необходимо при разработке алгоритмов и программ, так как в большинстве языков программирования есть логические операции Первые учения о формах и способах рассуждений возникли в странах древнего Востока (Китай, Индия).

История логики насчитывает более 2,5 тысяч лет. Первоначально она развивалась для образования отдельных разделов математики.

Аристотель (384г.-322г.до н.э.)

Впервые проблемы точного мышления были систематизированы и обобщены в трудах древнегреческого философа Аристотеля, которому удалось отделить логические формы мышления от содержания.

Аристотель приехал в Афины и поступил в школу - академию Платона, где пробыл 20 лет, сначала в качестве ученика, а затем в качестве учителя. Аристотель часто спорил со своим великим учителем, отстаивая свои философские идеи. Аристотель на всю свою жизнь сохранил уважение к своему Великому Учителю и ушел из академии только после его смерти.

В 335 г. до н.э. в предместье Афин Аристотель создал свою школу, которую назвал лицеем. Занимаясь преподавательской деятельностью, Аристотель не прерывал связи с Александром Македонским. В своих письмах царю, он предостерегал его от упоения властью, призывал ценить друзей и карать льстецов и наушников. Аристотель создавал логику как науку о доказательстве истины. Он подошел вплотную к теории доказательств. Но решить эту задачу даже очень гениальному человеку было не под силу. Потребовались тысячелетия упорного труда до получения результатов.

Готфрид Вильгельм Лейбниц (1646 – 1716)

В XVII веке немецкий ученый и философ Готфрид Вильгельм Лейбниц (1646 – 1716) попытался построить первые логические исчисления, усовершенствовал и уточнил логические символы.

Огромный титанический труд (около 75000 его работ хранятся в Ганноверском архиве) позволил ученому создать философскую систему, обогнав свое время на несколько столетий. Особый научный прорыв он совершил на стыке логики, математики, философии. Лейбниц был одним из первых, который всерьез интересовался двоичной системой счисления, в которой для счета достаточно двух цифр 0 и 1. Лейбниц взглянул на логику Аристотеля через призму математики:

Все известные понятия сводились к сочетанию простых понятий; разработал идею логического счисления, то есть сформулировал правила действия с символами; Простые рассуждения обозначались символами, сложные элементы логических высказываний обозначались формулами, а суждения – уравнениями; В результате удалось заменить содержательные высказывания формальными буквами, перейти к доказательству с помощью карандаша и бумаги.

Джордж Буль (1815-1864)

На фундаменте, заложенном Лейбницем, другой великий математик, англичанин Джордж Буль (1815-1864) воздвиг здание новой области науки – математической логики.
Начальный раздел математической логики называют алгеброй логики или Булевой алгеброй.

Он автор известных произведений “Математический анализ логики” (1847) и “Исследование законов мысли” (1857) родился в городе Линкольне (Англия) в семье мелкого торговца. Материальное положение родителей было трудным, платить за обучение сына было невозможно, прошлось ограничиться начальными классами для детей бедняков. Джордж изо всех сил стремился получить образование. Он самостоятельно овладел латынью и греческим. Страсть к науке делала его невосприимчивым к пренебрежительным взглядам. В 1844 году он получает золотую медаль за работу по математическому анализу.

Оригинальные идеи Буля по достоинству оценены математиком Кембриджского университета А. Де Морганом и Д.Грегори. Благодаря их поддержке, не имея высшего образования, ни степени, в 1849 году он стал профессором математики католического колледжа в ирландском городе Корк, где провел последние пятнадцать лет своей жизни.

Основное произведение Д.Буля “Исследование законов мысли”. В этой книге представлена алгебраическая система, которую называют алгеброй высказывания.

Что же это такое?

Джордж Буль представил логику как алгебру классов. Для обозначения классов использовал буквенные символы A, D, C, B и т.д. основными логическими операциями он считал: сложение классов, умножение классов, дополнение классов.

В булевой алгебре классы имеют только два значение “0” и “1”

Цифрой “1 ” Дж. Буль обозначал универсальное множество (класс), мыслимые элементы, т.е. - это ВСЕ, а “0” (нулевое множество ) – НИЧТО.

Буль разработал в своем труде основные логические операции:

В последние 3 десятилетия логика находит применение во многих областях в том числе в информатике, теории алгоритмов, кибернетике.

Клод Шеннон (1916-2001г)

Американский математик. В 1936 году выпускник Мичиганского университета Клод Шеннон, которому был тогда 21 год, сумел ликвидировать разрыв между алгебраической теорией логики и ее практическим приложением.

Так что же такое логика?


Контрольный тест

Вариант 1.

Вариант 2.

После прохождения теста позовите преподавателя!


Формы мышления

Логика - это наука о формах и способах мышления

Мышление всегда осуществляется в каких-то формах.

Основными формами мышления являются

  • понятие
  • высказывание
  • умозаключение

Понятие

Понятие выделяет существенные признаки объекта, которые отличают его от других объектов. Объекты, объединенные понятием образуют некоторое множество. Например, понятие "компьютер" объединяет множество электронных устройств, которые предназначены для обработки информации и обладают монитором и клавиатурой. Даже по этому короткому описанию компьютер трудно спутать с другими объектами, например с механизмами, служащими для перемещения по дорогам и хранящимся в гаражах, которые объединяются понятием "автомобиль".

Понятие имеет две стороны: содержание и объем.

Понятие - это форма мышления, фиксирующая основные, существенные признаки объекта.

Высказывание

О предметах можно судить верно или неверно, т.е. высказывание может быть истинным или ложным. Истинным будет суждение, в котором связь понятий правильно отражает свойства и отношения реальных вещей. Ложным суждение будет в том случае, когда связь понятий искажает объективные отношения, не соответствует реальной действительности.

Примером истинного высказывания может служить следующее: "Процессор является устройством обработки информации".

Ложным будет высказывание в том случае, когда оно не соответствует реальной действительности , например: "Процессор является устройством печати".

В естественном языке высказывания выражаются повествовательными предложениями. Высказывание не может быть выражено повелительным или вопросительным предложением, оценка истинности или ложности которых невозможна.
Высказывания могут выражаться с помощью математических, физических, химических и прочих знаков.
Из двух числовых выражений можно составить высказывания, соединив их знаками равенства или неравенства.
Высказывание называется простым, если никакая его часть сама не является высказыванием. Высказывание, состоящее из простых высказываний, называются составным (сложным).

Высказывание-это форма мышления , в которой что-либо утверждается или отрицается о свойствах реальных предметов и отношениях между ними. Высказывание может быть либо истинно, либо ложно.

Умозаключение

Умозаключение позволяет на основе известных фактов, выраженных в форме суждений(высказываний), получить заключение, то есть новыое знание. Примером умозаключений могут быть геометрические доказательства.

Напрмер, если мы имеем суждение "Все углы треугольника равны", то мы можем путем умозаключения доказать, что в этом случае справедливо суждение "Этот треугольник равносторонний".

Посылками умозакючения по правилам формальной логики могут быть только истинные суждения. Тогда, если умозаключение проводится в соответствии с правилами формальной логики, то оно будет истинным. В противном случае можно прийти к ложному умозаключению.

Умозаключение - это форма мышления, с помощью которой из одного или нескольких суждений(посылок) может быть получено новое суждение(заключение)

<а href="ik/11.jpg">Щелкните здесь, чтобы открыть файл.

Далее


Пройди тест

Какие из следующих предложений являются высказываниями? Определите их истинность.
В ответ запишите "является" или "не является"
1.

Наполеон был французским императором.

2.

Чему равно расстояние от Земли до Марса?

3.

Внимание! Посмотрите направо.

4.

Электрон-элементарная частица.

5.

Полярная Звезда находится в созвездии Малой Медведицы.

6.

Не все книги содержат полезную информацию.

7.

Некоторые ученики двоечники.

8.

Все ребята умеют плавать.

9.

У некоторых змей нет ядовитых зубов.

10.

Все солдаты храбрые.

11.

Выразите 1 час 15 минут в минутах.

Вы неправильно выполнили задания:
0.

1.

2.

3.

4.

5.

6.

7.

8.

9.

10.

11.


Упражнения (устная работа)

  1. Объясните, почему следующие предложения не являются высказываниями:
    • Какого цвета этот дом?
    • Число Х не превосходит единицы.
    • 4х+3.
    • Посмотрите в окно.
    • Пейте томатный сок!
    • Эта тема скучна.
    • Рикки Мартин - самый популярный певец.
    • Вы были в театре?
  2. Объясните, почему формулировка любой теоремы является высказыванием.
  3. Приведите по 2 примера истинных и ложных высказываний из математики, биологии, истории, информатики, литературы.
  4. Из следующих предложений выбрать те, которые являются высказываниями:
    • "Коля спросил: "Как пройти к Большому театру?"
    • " Как пройти в библиотеку?
    • " Картины Пикассо слишком абстрактны
    • " Решение задачи - информационный процесс
    • " Число 2 является делителем числа 7 в некоторой системе счисления.
  5. Выбрать истинные высказывания:
    • " Город Джакарта - столица Индонезии.
    • " Решение задачи - информационный процесс.
    • " Меню в программе - это список возможных вариантов
    • " Сканер - это устройство, которое может напечатать на бумаге то, что изображено на экране компьютера.
    • " Мышка - это устройство ввода информации.
  6. В приведенных предложениях вместо многоточия поставьте подходящие по смыслу слова "необходимо", "достаточно", "необходимо и достаточно". Получившиеся предложения должны быть истинными.
    • " Для того чтобы число делилось на 4, …, чтобы оно было четным.
    • " Для того чтобы число делилось на 3, …, чтобы оно делилось на 9.
    • " Для того чтобы число делилось на 10, … чтобы оно оканчивалось нулем.
    • " Чтобы произведение двух чисел равнялось нулю, …, чтобы каждое из них равнялось нулю.
    • " Чтобы произведение двух чисел равнялось нулю, …, чтобы хоть одно из них равнялось нулю.
    • " Чтобы умножить сумму нескольких чисел на какое-нибудь число, …, каждое слагаемое умножить на это число и произведения сложить.
    • " Чтобы произведение нескольких чисел разделить на какое-нибудь число, …, разделить на это число только один из сомножителей и полученное частное умножить на остальные сомножители.
    • " Для того чтобы сумма двух чисел была числом четным, …, чтобы каждое из слагаемых было четным числом.
    • " Для того чтобы число делилось на 10, …, чтобы делилось на 5.
    • " Для того чтобы число делилось на 6, …, чтобы делилось на 2 и на 3.
    • " Для того чтобы число делилось на 12, …, чтобы делилось на 2 и на 3.
    • " Чтобы четырехугольник был квадратом, …, чтобы все его стороны были равны.
    • " Для того чтобы прямоугольник был квадратом, …, чтобы все его стороны были равны.
    • " Чтобы периметр квадрата был равен 20 см, …, чтобы его сторона была равна 5 см.
    • " Чтобы площадь прямоугольника была равна 20 см2, …, чтобы его стороны были равны 4 см и 5 см.

[Ответы]


Упражнения

Пример 3

Приведите примеры истинных и ложных высказываний и запишите в тетрадь:
  • из арифметики;
  • из физики;
  • из биологии;
  • из информатики;
  • из геометрии
  • из жизни.

Пример 4

. Сформулируйте отрицания следующих высказываний или высказывательных форм и запишите в тетрадь:
  • “Эльбрус — высочайшая горная вершина Европы”;
  • “2>=5”;
  • “10<7”;
  • “все натуральные числа целые”;
  • “через любые три точки на плоскости можно провести окружность”;
  • “теннисист Кафельников не проиграл финальную игру”;
  • “мишень поражена первым выстрелом”;
  • “это утро ясное и теплое”;
  • “число n делится на 2 или на 3”;
  • “этот треугольник равнобедренный и прямоугольный”;
  • "на контрольной работе каждый ученик писал своей ручкой".

Пример 5

. Определите, какие из высказываний (высказывательных форм) в следующих парах являются отрицаниями друг друга, а какие нет:
  • “5<10”, “5>10”;
  • “10>9”, “10<=9”;
  • “мишень поражена первым выстрелом”, “мишень поражена вторым выстрелом”;
  • “машина останавливалась у каждого из двух светофоров”, “машина не останавливалась у каждого из двух светофоров”,
  • “человечеству известны все планеты Солнечной системы”, “в Солнечной системе есть планеты, неизвестные человечеству”;
  • “существуют белые слоны”, “все слоны серые”;
  • “кит — млекопитающее”, “кит — рыба”;
  • “неверно, что точка А не лежит на прямой а”, “точка А лежит на прямой а”;
  • “прямая а параллельна прямой b”, “прямая a перпендикулярна прямой b”;
  • “этот треугольник равнобедренный и прямоугольный”, “этот треугольник не равнобедренный или он не прямоугольный”.


Ответы

    В приведенных предложениях вместо многоточия поставьте подходящие по смыслу слова "необходимо", "достаточно", "необходимо и достаточно". Получившиеся предложения должны быть истинными.
    • " Для того чтобы число делилось на 4, …, чтобы оно было четным. (необходимо)
    • " Для того чтобы число делилось на 3, …, чтобы оно делилось на 9. (достаточно)
    • " Для того чтобы число делилось на 10, … чтобы оно оканчивалось нулем. (н д)
    • " Чтобы произведение двух чисел равнялось нулю, …, чтобы каждое из них равнялось нулю. (д)
    • " Чтобы произведение двух чисел равнялось нулю, …, чтобы хоть одно из них равнялось нулю. (н д)
    • " Чтобы умножить сумму нескольких чисел на какое-нибудь число, …, каждое слагаемое умножить на это число и произведения сложить. (д)
    • " Чтобы произведение нескольких чисел разделить на какое-нибудь число, …, разделить на это число только один из сомножителей и полученное частное умножить на остальные сомножители. (д)
    • " Для того чтобы сумма двух чисел была числом четным, …, чтобы каждое из слагаемых было четным числом. (д)
    • " Для того чтобы число делилось на 10, …, чтобы делилось на 5. (н)
    • " Для того чтобы число делилось на 6, …, чтобы делилось на 2 и на 3. (н д)
    • " Для того чтобы число делилось на 12, …, чтобы делилось на 2 и на 3. (н)
    • " Чтобы четырехугольник был квадратом, …, чтобы все его стороны были равны. (н)
    • " Для того чтобы прямоугольник был квадратом, …, чтобы все его стороны были равны. (н д)
    • " Чтобы периметр квадрата был равен 20 см, …, чтобы его сторона была равна 5 см.(н д)
    • " Чтобы площадь прямоугольника была равна 20 см2, …, чтобы его стороны были равны 4 см и 5 см. (д)


Самостоятельная работа. Вариант 1.

Самостоятельная работа

Вариант 1

  1. Какие из предложений являются высказываниями?
    1. Наполеон был французским императором.
    2. Чему равно расстояние от Земли до Марса?
    3. Внимание! Посмотрите направо.
    4. Электрон – элементарная частица
    5. Полярная Звезда находится в созвездии Малой Медведицы.
    6. Не нарушайте правил дорожного движения!
  2. Укажите истинные высказывания:
    1. Все ребята умеют плавать.
    2. Киев – столица Украины
    3. Некоторые кошки не любят рыбу.
    4. Человек все может.
    5. Невозможно создать вечный двигатель.
    6. Каждый человек – художник.
    7. Прямоугольник есть геометрическая фигура.
    8. Некоторые рыбы – хищники.
  3. Какие из приведенных высказываний являются ОБЩИМИ?
    1. Некоторые ученики двоечники.
    2. Все ананасы приятны на вкус.
    3. Мой кот страшный забияка.
    4. Любой неразумный человек ходит на руках.
    5. Тигр- хищное животное.
    6. У некоторых змей нет ядовитых зубов.
    7. Многие растения обладают целебными свойствами.
    8. Все металлы проводят тепло.
  4. Какие из приведенных высказываний являются ЧАСТНЫМИ?
    1. Некоторые ученики двоечники.
    2. Все ананасы приятны на вкус.
    3. Мой кот страшный забияка.
    4. Любой неразумный человек ходит на руках.
    5. Тигр- хищное животное.
    6. У некоторых змей нет ядовитых зубов.
    7. Многие растения обладают целебными свойствами.
    8. Все металлы проводят тепло.
  5. Вычислите значение логической функции: А и В , если А=ИСТИНА, В=ЛОЖЬ.
  6. Вычислите значение логической функции: А или (неВ) , если А=ЛОЖЬ, В=ИСТИНА.
  7. Постройте таблицу истинности логической функции: Zили (YиXилиZ).
  8. Как называют начинающего пользователя ЭВМ?
    1. Горшок
    2. кувшин
    3. чайник
    4. кофейник


Самостоятельная работа. Вариант 2.

Самостоятельная работа

Вариант 2

  1. Какие из предложений являются высказываниями?
    1. Чему равно произведение 23 на 56 ?
    2. Внимание! Посмотрите налево.
    3. Ион - заряженная частица.
    4. Иван Грозный был русским царем.
    5. Полярная Звезда находится в созвездии Малой Медведицы.
    6. Соблюдайте правила дорожного движения!
  2. Укажите истинные высказывания:
    1. Невозможно создать вечный двигатель.
    2. Каждый человек – художник.
    3. Прямоугольник есть геометрическая фигура.
    4. Некоторые рыбы – хищники.
    5. Все ребята умеют плавать.
    6. Киев – столица Украины.
    7. Некоторые кошки не любят рыбу.
    8. Человек все может.
  3. Какие из приведенных высказываний являются ОБЩИМИ?
    1. Некоторые ученики двоечники.
    2. Все ананасы приятны на вкус.
    3. Мой кот страшный забияка.
    4. Любой неразумный человек ходит на руках.
    5. Тигр- хищное животное.
    6. У некоторых змей нет ядовитых зубов.
    7. Многие растения обладают целебными свойствами.
    8. Все металлы проводят тепло.
  4. Какие из приведенных высказываний являются ЧАСТНЫМИ?
    1. Некоторые ученики двоечники.
    2. Все ананасы приятны на вкус.
    3. Мой кот страшный забияка.
    4. Любой неразумный человек ходит на руках.
    5. Тигр- хищное животное.
    6. У некоторых змей нет ядовитых зубов.
    7. Многие растения обладают целебными свойствами.
    8. Все металлы проводят тепло.
  5. Вычислите значение логической функции: А или В , если А=ИСТИНА, В=ЛОЖЬ.
  6. Вычислите значение логической функции: А и (неВ) , если А=ЛОЖЬ, В=ИСТИНА.
  7. Постройте таблицу истинности логической функции: Zили Zи (YилиXилиZ).
  8. Как называют начинающего пользователя ЭВМ?
    1. горшок
    2. кувшин
    3. чайник
    4. кофейник


Логические операции

Каждая логическая связка рассматривается как операция над логическими высказываниями и имеет свое название и обозначение.

Выделяют следующие логические операции: инверсия; конъюнкция; дизъюнкция; импликация; эквиваленция .

1. Операция инверсия (отрицание):

Отрицание - это логическая операция, которая каждому простому высказыванию ставит в соответствие составное высказывание, заключающееся в том, что исходное высказывание отрицается.

Обозначается: ол

В естественном языке: соответствует словам "неверно, что..." и частице "не"

Диаграмма Эйлера-Венна:

Принимаемые значения: лрл

Диаграмма Эйлера-Венна:

В алгебре множеств логическому отрицанию соответствует операция дополнения до универсального множества, т.е. множеству получившемуся в результате отрицания множества соответствует множество, дополняющее его до универсального множества.

Пример: Луна — спутник Земли (А). Луна — не спутник Земли ( [image] A)

2. Операция конъюнкция (лат. conjunctio — соединение) (логическое умножение):

Конъюнкция - это логическая операция, ставящая в соответствие каждым двум простым высказываниям составное высказывание, являющееся истинным тогда и только тогда, когда оба исходных высказывания истинны.

Обозначается: ол

В естественном языке: соответствует союзу "и"

Принимаемые значения: лрл

Диаграмма Эйлера-Венна:

В алгебре множеств конъюнкции соответствует операция пересечения множеств, т.е. множеству получившемуся в результате умножения множеств А и В соответствует множество, состоящее из элементов, принадлежащих одновременно двум множествам.

Примеры:

  1. 10 делится на 2 (A - и). 5 больше 3 (B - и). 10 делится на 2 и 5 больше 3 (A [image] B - и).
  2. 10 не делится на 2 (A - л). 5 больше 3 (B - и). 10 не делится на 2 и 5 больше 3 (A [image] B - л).
  3. 10 делится на 2 (A - и). 5 не больше 3 (B - л). 10 делится на 2 и 5 не больше 3 (A [image] B - л).
  4. 10 не делится на 2 (A - л). 5 не больше 3 (B - л). 10 делится на 2 и 5 больше 3 (A [image] B - л).

3. Операция дизъюнкция (лат. disjunctio — разделение) (логическое сложение):

Дизъюнкция - это логическая операция, которая каждым двум простым высказываниям ставит в соответствие составное высказывание, являющееся ложным тогда и только тогда, когда оба исходных высказывания ложны и истинным, когда хотя бы одно из двух образующих его высказываний истинно.

Обозначается: ол

В естественном языке: соответствует союзу "или"

Принимаемые значения: лрл

Диаграмма Эйлера-Венна:

В алгебре множеств дизъюнкции соответствует операция объединения множеств, т.е. множеству получившемуся в результате сложения множеств А и В соответствует множество, состоящее из элементов, принадлежащих либо множеству А, либо множеству В.

Примеры:

  1. 10 делится на 2 (A - и). 5 больше 3 (B - и). 10 делится на 2 или 5 больше 3 (A [image] B - и).
  2. 10 не делится на 2 (A - л). 5 больше 3 (B - и). 10 не делится на 2 или 5 больше 3 (A [image] B - и).
  3. 10 делится на 2 (A - и). 5 не больше 3 (B - л). 10 делится на 2 или 5 не больше 3 (A [image] B - и).
  4. 10 не делится на 2 (A - л). 5 не больше 3 (B - л). 10 не делится на 2 или 5 не больше 3 (A [image] B - л).

4. Операция импликация (лат. лат. implico — тесно связаны) (логическое сложение):

Импликация - это логическая операция, ставящая в соответствие каждым двум простым высказываниям составное высказывание, являющееся ложным тогда и только тогда, когда условие (первое высказывание) истинно, а следствие (второе высказывание) ложно.

Обозначается: ол

В естественном языке: соответствует обороту "если ..., то ..."

Принимаемые значения: лрл

Примеры:

  1. Данный четырёхугольник — квадрат (A - и). Около данного четырёхугольника можно описать окружность (B - и). Если данный четырёхугольник квадрат, то около него можно описать окружность (A [image] B - и).
  2. Данный четырёхугольник — не квадрат (A - л). Около данного четырёхугольника можно описать окружность (B - и). Если данный четырёхугольник не квадрат, то около него можно описать окружность (A [image] B - и).
  3. Данный четырёхугольник — квадрат (A - и). Около данного четырёхугольника нельзя описать окружность (B - л). Если данный четырёхугольник квадрат, то около него можно описать окружность (A [image] B - л).
  4. Данный четырёхугольник — не квадрат (A - л). Около данного четырёхугольника нельзя описать окружность (B - л). Если данный четырёхугольник не квадрат, то около него нельзя описать окружность (A [image] B - и).

5. Операция эквиваленция (двойная импликация):

Эквиваленция – это логическая операция, ставящая в соответствие каждым двум простым высказываниям составное высказывание, являющееся истинным тогда и только тогда, когда оба исходных высказывания одновременно истинны или одновременно ложны.

Обозначается: ол

В естественном языке: соответствует оборотам речи "тогда и только тогда"; "в том и только в том случае"

Принимаемые значения: лрл

Примеры:

  1. 24 делится на 6 (A - и). 24 делится на 3 (B - и). 24 делится на 6 тогда и только тогда, когда 24 делится на 3 (A [image] B - и).
  2. 24 не делится на 6 (A - л). 24 делится на 3 (B - и). 24 не делится на 6 тогда и только тогда, когда 24 делится на 3 (A [image] B - л).
  3. 24 делится на 6 (A - и). 24 не делится на 3 (B - л). 24 делится на 6 тогда и только тогда, когда 24 делится на 3 (A [image] B - л).
  4. 24 не делится на 6 (A - л). 24 не делится на 3 (B - л). 24 не делится на 6 тогда и только тогда, когда 24 не делится на 3 (A [image] B - и).

Порядок выполнения логических операций:

  • операция в скобках;
  • отрицание;
  • логическое умножение (конъюнкция);
  • логическое сложение (дизъюнкция);
  • ипликация;
  • эквиваленция;

Для изменения указанного порядка выполнения операций используются скобки.


Решение задач

Способы решения логических задач

Существует три способа решения логических задач:

  • Средствами алгебры логики.
  • Табличный.
  • С помощью рассуждений.

Прежде, чем приступать к решению задач, необходимо процесс решения логических задач разбить на этапы.

Схема решения логических задач:

  • Изучается условие задачи.
  • Вводится система обозначений.
  • Составляется логическая формула.
  • Определяется значения логической формулы.


Решение задач

Решение задач средствами алгебры логики

Пример 1.

Записать в виде логического выражения следующее высказывание: "Летом Петя поедет в деревню и, если будет хорошая погода, то он пойдет на рыбалку".
  1. Проанализируйте составное высказывание:

    Оно состоит из следующих простых высказываний:

    1. A=Петя поедет в деревню;
    2. В=Будет хорошая погода;
    3. С=Он пойдет на рыбалку;
  2. Запишем высказывание в виде логического выражения, учитывая порядок действий. Если необходимо, расставим скобки:

  3. Ответ:

Пример 2.

Формализуйте предостережение, которое одна жительница древних Афин сделала своему сыну, собиравшемуся заняться политической деятельностью: “Если ты будешь говорить правду, то тебя возненавидят люди. Если ты будешь лгать, то тебя возненавидят боги. Но ты должен говорить правду или лгать. Значит, тебя возненавидят люди или возненавидят боги”.

Формализуйте также ответ сына: “Если я буду говорить правду, то боги будут любить меня. Если я буду лгать, то люди будут любить меня. Но я должен говорить правду или лгать. Значит, меня будут любить боги или меня будут любить люди”.

Ответ: Решение.

Введем обозначения для логических высказываний: а – “ты будешь говорить правду”; b – “тебя возненавидят люди”; c – “тебя возненавидят боги”. Договоримся считать, что некоторое заданное высказывание x истинно, если нет оговорки. Тогда предостережение матери можно записать так:

Пример 3.

. Пусть a = “это утро ясное”, а b = “это утро теплое”. Выразите следующие формулы на обычном языке:

Ответ:

а) “это утро ясное и тёплое”; ж) “это утро не ясное или не тёплое”;
б) “это утро ясное и оно не тёплое”; з) “это утро не ясное и не тёплое”;
в) “это утро не ясное и оно не тёплое”; и) “это утро ясное или не тёплое”;
г) “это утро не ясное или оно тёплое”; к) “если это тро ясное, то оно не тёплое”;
д) “это утро ясное или оно не тёплое”; л) “если это утро не ясное, то оно тёплое”;
е) “это утро не ясное или оно не тёплое”; м) “это утро ясное и не тёплое”.

Пример 4.

Из двух данных высказываний a и b постройте составное высказывание, которое было бы:

  • а) истинно тогда и только тогда, когда оба данных выказывания ложны;
  • б) ложно тогда и только тогда, когда оба данных высказывания истинны.

Пример 5.

. Из трех данных высказываний a, b, c постройте составное высказывание, которое истинно, когда истинно какое-либо одно из данных высказываний, и только в этом случае.

. .


Решение задач

Решение задач с помощью построения таблиц истинности

Таблица истинности

Решение логических выражений принято записывать в виде таблиц истинности-таблиц, в которых по действиям показано какие значения принимает логическое выражение при всех возможных выборах его переменных.
Для составления таблиц необходимо:
  1. Выяснить количество строк в таблице (вычисляется по формуле 2n, где n-количество пременных
  2. Выяснить количество столбцов+количество переменных + количество логических операций
  3. Установить последовательность выполнения логических операций
  4. Построить таблицу, указывая названия столбцов и возможные выборы значений исходных логических переменных.
  5. Заполнить таблицу истинности по столбцам

Пример 1.

Построить таблицу истинности следующей логической функции F=(A∨B)∧(¬A∨¬B)

В нашем случае функция имеет 2 переменные, поэтому количество строк в таблице истинности будет равно 22=4.
Во-вторых, необходимо определить количество столбцов в таблице истинности , которое равно количеству логических переменных плюс количество логических операций.
В нашем случае количество пременных равно 2, а количество логических операций - 5, то есть количество столбцов таблицы истинности равно 7.

Ответ: Решение.

A | B | A∨B | ¬A | ¬B | ¬A∨¬B | F=(A∨B)∧(¬A∨¬B)
0 | 0 | 0 | 1 | 1 | 1 | 0
0 | 1 | 1 | 1 | 0 | 1 | 1
1 | 0 | 1 | 0 | 1 | 1 | 1
1 | 1 | 1 | 0 | 0 | 0 | 0

Пример 2.

Построим таблицу истинности для логического выражения X∨Y∧¬Z.
  1. Количество строк равно 23+1=9
  2. Количество столбцов равно 3 логичесие переменные плюс 3 логических операции=6
  3. Укажем порядок действий: 3,2,1
X | Y | Z | ¬Z | Y∧¬Z | X∨Y∧¬Z
0 | 0 | 0 | 1 | 0 | 0
0 | 0 | 1 | 0 | 0 | 0
0 | 1 | 0 | 1 | 1 | 1
1 | 0 | 0 | 1 | 0 | 1
1 | 0 | 1 | 0 | 0 | 1
1 | 1 | 0 | 1 | 1 | 1
1 | 1 | 1 | 0 | 0 | 1

Пример 3.

Решение:

1 способ: Построим таблицу истинности для каждого из четырех высказываний и сравним с данной таблицей истинности.

F=X∧Y∧Z
F=¬X∨¬Y∨Z

X | Y | Z | F
0 | 0 | 0 | 0
0 | 0 | 1 | 0
1 | 1 | 1 | 1

X | Y | Z | F
0 | 0 | 0 | 0
0 | 0 | 1 | 1
1 | 1 | 1 | 1
F=X∨Y∨Z
F=¬X∧¬Y∧¬Z

X | Y | Z | F
0 | 0 | 0 | 0
0 | 0 | 1 | 1
1 | 1 | 1 | 1

X | Y | Z | F
0 | 0 | 0 | 0
0 | 0 | 1 | 1
1 | 1 | 1 | 1

Ответ: 1)

Пример 4.

Составить таблицу истинности для формулы
¬ (B /\ C) V (A/\C→ B)
Порядок выполнения логических операций:
¬ (B /\ C) V (A/\C→ B)
2 1 5 3 4
Составить таблицу истинности.
Сколько строк будет в вашей таблице? 3 переменных: А, В, С; 23 = 8
Сколько столбцов? 5 операций + 3 переменных = 8

Решение

A | B | C | (B /\ C) | ¬ (B /\ C) | A/\C | (A/\C → B) | ¬ (B /\ C) V (A/\C→ B)
0 | 0 | 0 | 0 | 1 | 0 | 1 | 1
0 | 0 | 1 | 0 | 1 | 0 | 1 | 1
0 | 1 | 0 | 0 | 1 | 0 | 1 | 1
0 | 1 | 1 | 1 | 0 | 0 | 1 | 1
1 | 0 | 0 | 0 | 1 | 0 | 0 | 1
1 | 0 | 1 | 0 | 1 | 1 | 1 | 1
1 | 1 | 0 | 0 | 1 | 0 | 0 | 1
1 | 1 | 1 | 1 | 0 | 1 | 1 | 1

Какие ответы получились в последнем столбце?

Ответ: 1

Логическое выражение называется тождественно-истинным, если оно принимает значения 1 на всех наборах входящих в него простых высказываний. Тождественно-истинные формулы называют тавтологиями.

Решим этот пример аналитическим методом:
Упрощаем выражение
¬ (B /\ C) V (A/\C → B)= (применим формулу для импликации)
¬ (B /\ C) V ¬ (A /\ C) V B = (применим 1 и 2 законы де Моргана)
(¬B V ¬C) V (¬A V ¬C) V B = (уберём скобки)
¬B V ¬C V ¬A V ¬C V B= (применим переместительный закон)
¬B V B V ¬C V ¬C V ¬A = (закон исключения третьего, закон идемпотентности)
1 V ¬С V ¬A = 1 V ¬A = 1 (закон исключения констант)
Ответ: 1, означает, что формула является тождественно-истинной или тавтологией.
Логическое выражение называется тождественно-ложным, если оно принимает значения 0 на всех наборах входящих в него простых высказываний.


Решение задач

Задачи

Задание 1. Составьте таблицы истинности для следующих логических выражений

  1. F=X∧Y∨X
  2. F=(X∧¬Y)∨Z
  3. F=¬(X∨Y)∧(Y∨X)
  4. F=A∧B∧C∧¬D
  5. F=(A∨B)∧(¬B∨A∨B)

Задание 2. Заполните пустые ячейки таблицы истинности (работу выполнить в тетради)

A | B | C | C∨A | (C∨A)→B
0 | 0 |  | 0 | 1
0 |  | 0 | 0 | 1
 | 0 | 1 | 1 | 0
1 | 1 | 1 | 1 |


Решение задач

Ответы

Пример 1. Ответ: Решение.

  1. Количество строк равно 22+1=5
  2. Количество столбцов равно: 2 логичесие переменные плюс 2 логических операции=4
  3. Укажем порядок действий: 1,2

X | Y | X∧Y | X∧Y∨X
0 | 0 | 0 | 0
0 | 1 | 0 | 0
1 | 0 | 0 | 1
1 | 1 | 1 | 1

Пример 2 Ответ. Решение..

  1. Количество строк равно 23+1=9
  2. Количество столбцов равно 3 логичесие переменные плюс 3 логических операции=6
  3. Укажем порядок действий: 2,1,3

X | Y | Z | ¬Y | Y∧¬Y | (Y∧¬Y)∨Z
0 | 0 | 0 | 1 | 0 | 0
0 | 0 | 1 | 1 | 0 | 1
0 | 1 | 0 | 0 | 0 | 0
1 | 0 | 0 | 1 | 1 | 1
0 | 1 | 1 | 0 | 0 | 1
1 | 0 | 1 | 1 | 1 | 1
1 | 1 | 0 | 0 | 0 | 0
1 | 1 | 1 | 0 | 0 | 1

Пример 3. Ответ: Решение.

  1. Количество строк равно 22+1=5
  2. Количество столбцов равно: 2 логичесие переменные плюс 3 логических операции=5
  3. Укажем порядок действий: 1,2,3

X | Y | X∨Y | ¬(X∨Y) | ¬(X∨Y)∧(Y∨X)
0 | 0 | 0 | 1 | 0
0 | 1 | 1 | 0 | 0
1 | 0 | 1 | 0 | 0
1 | 1 | 1 | 0 | 0

Пример 4 Ответ. Решение.

  1. Количество строк равно 24+1=17
  2. Количество столбцов равно 4 логичесие переменные плюс 4 логических операции=8
  3. Укажем порядок действий: 4,1,2,3

A | B | C | D | ¬D | A∧B | A∧B∧C | A∧B∧C∧¬D
0 | 0 | 0 | 0 | 1 | 0 | 0 | 0
0 | 0 | 0 | 1 | 0 | 0 | 0 | 0
0 | 0 | 1 | 0 | 1 | 0 | 0 | 0
1 | 1 | 0 | 0 | 1 | 0 | 0 | 0
1 | 0 | 0 | 0 | 1 | 0 | 0 | 0
1 | 1 | 0 | 0 | 1 | 1 | 0 | 0
1 | 0 | 1 | 0 | 1 | 0 | 0 | 0
0 | 1 | 0 | 1 | 0 | 1 | 0 | 0
1 | 0 | 0 | 1 | 0 | 0 | 0 | 0
0 | 0 | 1 | 1 | 0 | 0 | 0 | 0
0 | 1 | 1 | 0 | 1 | 0 | 0 | 0
1 | 1 | 1 | 0 | 1 | 1 | 1 | 1
1 | 1 | 0 | 1 | 0 | 1 | 0 | 0
1 | 0 | 1 | 1 | 0 | 0 | 0 | 0
0 | 1 | 1 | 1 | 0 | 0 | 0 | 0
1 | 1 | 1 | 1 | 0 | 1 | 1 | 0

Пример 5. Ответ: Решение.

  1. Количество строк равно 22+1=5
  2. Количество столбцов равно: 2 логичесие переменные плюс 5 логических операции=7
  3. Укажем порядок действий: 1,2

A | B | A∨B | ¬B | ¬B∨A | ¬B∨A∨B | (A∨B)∧(¬B∨A∨B)
0 | 0 | 0 | 1 | 1 | 0 | 0
0 | 1 | 1 | 0 | 0 | 0 | 0
1 | 0 | 1 | 1 | 1 | 0 | 0
1 | 1 | 1 | 0 | 1 | 1 | 1

Задание 2. Ответ. Решение. (за помощью обратись к странице "Основные логические операции")

A | B | C | C∨A | (C∨A)→B
0 | 0 | 0 | 0 | 1
0 | 1 | 0 | 0 | 1
0 или 1 | 0 | 1 | 1 | 0
1 | 1 | 1 | 1 | 1


Тест на соответствие

Знаешь ли ты основные логические операции?

Чтобы приступить к выполнению задания, перейди по следующей ссылке

По окончании работы пригласите учителя!


Практическая работа тренировочного характера

Инструкция

Практическая работа состоит из 5 заданий, выполняемых последовательно.

Щелкая на пустых ячейках выбирайте нужную цифру из появившегося меню. Если вы ошиблись, сделайте повторный выбор. Когда ячейки заполнены полностью, становится доступной кнопка [далее].

Если все заполнено верно, то происходит переход на другое задание. Если есть ошибки, то они будут выделены желтым цветом: Для перехода к другому заданию их нужно исправить и снова нажать кнопку [далее].

Чтобы приступить к выполнению задания, перейди по следующей ссылке

По окончании работы пригласите учителя!


Основные законы логики

Законы логики отражают наиболее важные закономерности логического мышления. В алгебре высказываний законы логики записываются в виде формул, которые позволяют проводить эквивалентные преобразования логических выражений.

Закон тождества

Всякое высказывание тождественно самому себе:

A = A

Закон непротиворечия

Высказывание не может быть одновременно истинным и ложным. Если высказывание А истинно, то его отрицание не А должно быть ложным. Следовательно, логическое произведение высказывания и его отрицания должно быть ложно:

A ∧¬A = 0

Закон исключенного третьего

Высказывание может быть либо истинным, либо ложным, третьего не дано. Это означает, что результат логического сложения высказывания и его отрицания всегда принимает значение "истина":

A ∨¬A = 1

Закон двойного отицания

Если дважды отрицать некоторое высказывание, то в результате мы получим исходное высказывание:

¬¬A = A
.

Закон поглощения

:
Логическое умножение | Логическое сложение
A∨(A ∧ B) = A | A ∧(A ∨ B) = A A

:

Законы де Моргана

¬(A∨B) = ¬A ∧ ¬B
¬(A∧B) = ¬A ∨ ¬B

Закон контрпозиции

A → B = ¬ A → ¬ B

Способ приведения формул к нормальной форме.

Формула имеет нормальную форму, если в ней отсутствуют знаки эквивалентности, импликации, двойного отрицания, при этом знаки отрицания находятся только при переменных.

¬(A → B) = A ∧ ¬ B
¬(A → B) = ¬A ∨ B
A ↔B=(A ∧ B) ∨ (¬A ∧¬B)=(¬A ∨ B) ∧ (A ∨¬B)

Важное значение для выполнения преобразований логических выражений имеют законы алгебраических преобразований. Многие из них имеют аналоги в обычной алгебре.

Закон коммутативности

В обычной алгебре слагаемые и множители можно менять местами. В алгебре высказываний можно менять местами логические переменные при операциях логического умножения и логического сложения:

Логическое умножение | Логическое сложение
A ∧ B = B ∧ A | A ∨; B = B ∨ A

Закон ассоциативности

Если в логическом выражении используются только операции логического умножения или только логического сложения , то можно пренебрегать скобками или произвольно их расставлять:

Логическое умножение | Логическое сложение
(A ∧ B )∧ C=A ∧ (B∧C) | (A ∨ B )∨ C=A ∨ (B∨C)

Закон дистрибутивности

В отличие от обычной алгебры, где за скобки можно выносить только общие множители, в алгебре высказываний можно выносить за скобки как общие множители, так и общие слагаемые:

Дистрибутивность умножения относительно сложения | Дистрибутивность сложения относительно умножения
A(b+c) = a(b+c) - в алгебре (A ∧ B )∨(A∧ C)=A ∧ (B∨C) | (A ∨ B )∧(A∨ C)=A ∨ (B∧C)


Логические операции

Удобным способом представления логических выражений являются логические схемы. Вот как изображаются на таких схемах три основные логические операции:

В этой таблице использованы следующие обозначения:
1 - истина; 0 - ложь;

Цифры в начале входящих стрелок - логичесие операнды; цифры в конце выходящих стрелок - результаты операций.

Данная таблица - та же таблица истинности, только представленная в форме логических схем. В такой форме удобно изображать цепочки логических операций и производить их вычисления.


Решение задач

Примеры

Пример 1.

Для вычисления логического выражения : 1 или 0 и 1 нарисовать схему, отражающую последовательность выполнения логических операций. По схеме вычислить значение логического выражения.

Решение:

Здесь наглядно отражено то, что первой выполняется операция и, затем или. Теперь в порядке слева-направо припишем к выходящим стрелкам результаты операций:

В результате получилась 1, т.е. "истина".

Пример 2.

Дано выражение не (1 и (0 или 1) и 1).
Вычислить значение выражения с помощью логической схемы.

Решение:
Логическая схема с результатами вычислений выглядит так:

В результате получился 0, т.е. "ложь".


Задачи.

Задача 1.

Пусть a, b, c - логические величины, которые имеют следующие значения: a=истина, b=ложь , c=истина. Нарисуйте логические схемы для следующих логических выражений и вычислите их значения:

1)a и b; | 4) а и в или с; | 7) (а или в) и (с или в);
2) а или в; | 5) а или в и с; | 8) не(а или в) и (с или в);
3) не а или в; | 6) не а или в и с; | 9) не (а и в и с);

[Решение]

Задача 2.

Построить логические схемы по логическому выражению:

  1. X 1 и (не X 2 или X 3);
  2. X 1 и X 2 или не X 1 и X 3;
  3. X 4 и (X 1 и X 2 и X 3 или не X 2 и не X 3).

[Решение]

Задача 3.

Выполните вычисления по логическим схемам. Запишите соответствующие логические выражения::

1)
2)

[Решение]

Задача 4.

Дана логическая схема. Построить логические выражения, соответствующие схеме. Вычислить значение выражения для:

а) X 1=0, X 2=1; | в) X 1=1, X 2=1;
а) X 1=1, X 2=0; | в) X 1=0, X 2=0;

[Решение]


Ответы.

Задача 1.

Пусть a, b, c - логические величины, которые имеют следующие значения: a=истина, b=ложь , c=истина. Нарисуйте логические схемы для следующих логических выражений и вычислите их значения:

1)a и b; | 4) а и в или с; | 7) (а или в) и (с или в);
2) а или в; | 5) а или в и с; | 8) не(а или в) и (с или в);
3) не а или в; | 6) не а или в и с; | 9) не (а и в и с);

Решение:

1) | 5)
2) | 6)
3) | 7)
4) | 8)
 | 9)

Задача 2.

Построить логические схемы по логическому выражению:

  1. X 1 и (не X 2 или X 3);
  2. X 1 и X 2 или не X 1 и X 3;
  3. X 4 и (X 1 и X 2 и X 3 или не X 2 и не X 3).

Решение:

Ответ к заданию 1:

Ответ к заданию 2:

Ответ к заданию 3:

Задача 3.

Выполните вычисления по логическим схемам. Запишите соответствующие логические выражения::

1)
2)

Решение:

1)
2)

Задача 4.

Дана логическая схема. Построить логические выражения, соответствующие схеме. Вычислить значение выражения для:

а) X 1=0, X 2=1; | b) X 1=1, X 2=1;
c) X 1=1, X 2=0; | d) X 1=0, X 2=0;

Решение:

  1. Логическое выражение, соответствующее схеме: ((¬X1∧X2)∨X1)∧¬X2
  2. Вычисление значений выражений
    1. Если X 1=0, X 2=1, то ((1∧1)∨0)∧0=0;
    2. Если X 1=1, X 2=1, то ((0∧1)∨1)∧0=0;
    3. Если X 1=1, X 2=0, то ((0∧0)∨1)∧1=1;
    4. Если X 1=0, X 2=0, то ((1∧0)∨0)∧1=0;


Самостоятельная работа. Вариант 1.

Примеры

Пример 1

Пояснение

(законы алгебры логики применяются в следующей последовательности: правило де Моргана, сочетательный закон, правило операций переменной с её инверсией и правило операций с константами);

Пример 2

Пояснение

(применяется правило де Моргана, выносится за скобки общий множитель, используется правило операций переменной с её инверсией);

Пример 3

Пояснение

(повторяется второй сомножитель, что разрешено законом идемпотенции; затем комбинируются два первых и два последних сомножителя и используется закон склеивания);

Пример 4

Пояснение

(вводится вспомогательный логический сомножитель (Y∨¬Y ); затем комбинируются два крайних и два средних логических слагаемых и используется закон поглощения);

Пример 5

Пояснение

(сначала добиваемся, чтобы знак отрицания стоял только перед отдельными переменными, а не перед их комбинациями, для этого дважды применяем правило де Моргана; затем используем закон двойного отрицания);

Пример 6

Пояснение

(выносятся за скобки общие множители; применяется правило операций с константами);

Пример 7

Упростить следующую логическую формулу

Решение:


Самостоятельная работа. Вариант 1.

Решить самостоятельно

Пример 1

Представим такую ситуацию: по телевизору синоптик объявляет прогноз погоды на завтра и утверждает следующее:

  1. Если не будет ветра, то будет пасмурная погода без дождя.
  2. Если будет дождь, то будет пасмурно и без ветра.
  3. Если будет пасмурная погода, то будет дождь и не будет ветра.

Так какая же погода будет завтра?
Решим эту задачу средствами алгебры логики.

Решение:

  1. Выделим простые высказывания и запишем их через переменные:
    A – «Ветра нет»
    B – «Пасмурно»
    С – «Дождь»
  2. Запишем логические функции (сложные высказывания) через введенные переменные:
  1. Если не будет ветра, то будет пасмурная погода без дождя: A → B ∧¬C;
  2. . Если будет дождь, то будет пасмурно и без ветра: С → B & A
  3. Если будет пасмурная погода, то будет дождь и не будет ветра B → C ∧ A
  4. Запишем произведение указанных функций: F= A → B ∧¬C∧С → B & A∧ B → C ∧ A
  5. Упростим формулу (используются законы де Моргана, переместительный закон, закон противоречия):
    F=A → B ∧¬C∧С → B & A∧ B → C ∧ A =
    (¬A v B ∧¬ C) ∧ (¬C v B∧A) ∧ (¬B v C∧A) = (¬A ∧¬C V B ∧¬ C V B ∧¬C ∧¬ A) ∧(¬ B V C V A)=
    ((¬A ∧¬C V B ∧¬ C ∧ (1 V ¬ A)) ∧(¬ B V C V A)=
    (¬A ∧¬C V B ∧¬ C ∧ ¬ A)∧(¬ B V C V A)=
    ((¬A ∧¬C) ∧ (1 V B))∧(¬ B V C V A)=
    ((¬A ∧¬C ∧ B) ∧ (¬B V C ∧¬ A) =
    ¬A ∧¬C ∧ ¬B V ¬ A ∧ ¬ C ∧ B ∧ C ∧¬ A =
    ¬A ∧¬C ∧ ¬B
  6. Приравняем результат к единице, т.е. наше выражение должно быть истинным: F = ¬A ∧ ¬B ∧ ¬C = 1
  7. Проанализируем результат:

Логическое произведение равно 1, если каждый множитель равен 1. Поэтому: ¬ A = 1; ¬ B = 1; ¬C = 1;
Значит: A = 0; B = 0; C = 0;

Ответ:

погода будет ясная, без дождя, но ветреная.


Самостоятельная работа. Вариант 1.

Табличный метод решения логических задач

Задача 1

Один из четырех мальчиков испортил выключатель. На вопрос "Кто это сделал?" были получены такие ответы:

  1. "Это сделал или Миша или Коля";
  2. "Это сделал или Витя или Коля";
  3. "Это не могли сделать ни Толя.ни Миша";
  4. "Это сделал или Витя, или Миша";
Можно ли по этим данным установить, кто виновен в поломке выключателя, если известно, что из четырех высказываний три истинны?

Решение

Обозначим через М высказывание "Виноват Миша, В - "Виноват Коля", Т - "Виноват Толя". Тогда ответы на вопросы о виновнике поломки описываются следующими формулами алгебры высказываний:

  1. M ∨ K;
  2. B ∨ K;
  3. ¬T ∧ ¬M;
  4. B ∨ M

В первые 4 столбца таблицы поместим значения высказываний M,B,K,T, в столбцы с 5-го по 8-й поместим значения высказываний (1) - (4). Так как виноват только один из 4-х мальчиков, количество строк в таблице равно 4, причем первые 4 столбца таблицы содержат только по одному значению "истина"(единицу), а остальные - "ложь"(ноль). Значения в столбцах с 5-го по 8-й вычисляем в соответствии с записанными формулами.

M | B | R | T | (1) | (2) | (3) | (4)
1 | 0 | 0 | 0 | 1 | 0 | 0 | 1
0 | 1 | 0 | 0 | 0 | 1 | 1 | 1
0 | 0 | 1 | 0 | 1 | 1 | 1 | 0
0 | 0 | 0 | 1 | 0 | 0 | 0 | 0

Из таблицы видно, что возможны два варианта одновременной истинности трех ответов: из четырех строк таблицы две (2-я и 3-я) содержат по 3 единицы. Но эти строки соответствуют значениям истинности для высказывания В и К. Следовательно, виноват или Витя, или Коля, т.е. однозначно ответить на вопрос "Кто виноват?" при заданных условиях нельзя.
Ответ: По ответам, данными мальчиками, определить виновника нельзя.


Самостоятельная работа. Вариант 1.

Табличный метод решения логических задач

Решить самостоятельно

Один из трех братьев Витя, Толя или Коля - разбил окно. В разговоре участвуют еще 2 брата - Андрей и Дима.

  1. "Это мог сделать только Витя, или Толя, - сказал Андрей.";
  2. "Я окно не разбивал, - Возразил Витя, - и Коля тоже.";
  3. "Вы оба говорите неправду, - возразил Толя.";
  4. "Нет, Толя, один из них сказал правду, а другой сказал неправду, - возразил Дима";
  5. "Ты, Дима, не прав, - вмешался Коля";

Их отец, которому, конечно, можно доверять, уверен, что трое из пяти братьев сказали правду. Кто разбил окно?

Ответ:Окно разбил Толя (докажите это)

Решить самостоятельно

Восемь школьников, остававшихся в классе на перемене, были вызваны к директору. Один из них разбил окно

  1. "Это мог сделать только Витя, или Толя, - сказал Андрей.";
  2. "Я окно не разбивал, - Возразил Витя, - и Коля тоже.";
  3. "Вы оба говорите неправду, - возразил Толя.";
  4. "Нет, Толя, один из них сказал правду, а другой сказал неправду, - возразил Дима";
  5. "Ты, Дима, не прав, - вмешался Коля";

Их отец, которому, конечно, можно доверять, уверен, что трое из пяти братьев сказали правду. Кто разбил окно?

Ответ:Окно разбил Толя (докажите это)

В первые 4 столбца таблицы поместим значения высказываний M,B,K,T, в столбцы с 5-го по 8-й поместим значения высказываний (1) - (4). Так как виноват только один из 4-х мальчиков, количество строк в таблице равно 4, причем первые 4 столбца таблицы содержат только по одному значению "истина"(единицу), а остальные - "ложь"(ноль). Значения в столбцах с 5-го по 8-й вычисляем в соответствии с записанными формулами.

M | B | R | T | (1) | (2) | (3) | (4)
1 | 0 | 0 | 0 | 1 | 0 | 0 | 1
0 | 1 | 0 | 0 | 0 | 1 | 1 | 1
0 | 0 | 1 | 0 | 1 | 1 | 1 | 0
0 | 0 | 0 | 1 | 0 | 0 | 0 | 0

Из таблицы видно, что возможны два варианта одновременной истинности трех ответов: из четырех строк таблицы две (2-я и 3-я) содержат по 3 единицы. Но эти строки соответствуют значениям истинности для высказывания В и К. Следовательно, виноват или Витя, или Коля, т.е. однозначно ответить на вопрос "Кто виноват?" при заданных условиях нельзя.
Ответ: По ответам, данными мальчиками, определить виновника нельзя.


Решение задач(самостоятельно)

Построение таблиц истинности по булевому выражению

Алгоритм

  1. Определить число переменных

  2. Определить количество логических операций и их порядок

  3. Построить для каждой логической операции свою схему (если это возможно)

  4. Объединить логические схемы в порядке выполнения логических операций

Задание 1

Построить по булевому выражению табицу истиинности

Задание 2

Построить по булевому выражению табицу истиинности

Задание 3

Построить по булевому выражению табицу истиинности


Решение задач(самостоятельно)

Построение булева выражения по логической схеме

Алгоитм

  1. На выходе каждого логического элемента записать результат логической операции

  2. Записать получившуюся формулу на выходе последнего элемента

  3. Упростить получившуюся формулу

Задание 1

Построить булево выражение по логической схеме:

Задание 2

Построить булево выражение по логической схеме:

Задание 3*

Индивилуальная работа по карточкам. Какой сигнал получится на выходе схемы (в точке E)


Решение задач(самостоятельно)

Построение логических схем по булевому выражению

Алгоритм

  1. Определить число переменных

  2. Определить количество логических операций и их порядок

  3. Построить для каждой логической операции свою схему (если это возможно)

  4. Объединить логические схемы в порядке выполнения логических операций

Задание 1

Построить по булевому выражению логическую схему

Задание 2

Построить по булевому выражению логическую схему

Задание 3

Построить по булевому выражению логическую схему

Задание 4*

Индивилуальная работа по карточкам. Исходя из данной таблицы – определить маркировку логического элемента


Решение задач рассуждениями

III. Решение логических задач с помощью рассуждений

Этим способом обычно решают несложные логические задачи.

Пример 1.

В соревнованиях по плаванию участвовали Андрей, Виктор, Саша и Дима.
Их друзья высказали предположения о возможных победителях:
1) первым будет Саша, Виктор будет вторым;
2) вторым будет Саша, Дима будет третьим;
3) Андрей будет вторым, Дима будет четвёртым.

По окончании соревнований оказалось, что в каждом из предположений только одно из высказываний истинно, другое ложно. Какое место на соревнованиях занял каждый из юношей, если все они заняли разные места.

Пусть Саша (С), Виктор (В), Дима (Д), Андрей (А), то:

  1. С-1, В-2
  2. С-2, Д-3
  3. А-2, Д-4

Составим уравнения:

  1. C1∧B2=0
  2. C2∧Д3=0
  3. А2∧Д4=0
  4. С1∨В2=1
  5. С2∨Д3=1
  6. А2∨Д4=1
  7. С1∧С2=0
  8. Д3∧Д4=0
  9. В2∧С2=0
  10. В2∧А2=0
  11. С2∧А2=0

Умножим (4) на (5):
(С1∨В2)∧(С2∨Д3)=1
С1∧С2∨В2∧С2∨С1∧Д3∨В2∧Д3=1
Т. к. С1∧С2=0 (7) и В2∧С2=0 (9), то
С1∧Д3∨В2∧Д3=1
Д3∧(С1∨В2)=1
Д3=1 => в (8) Д4=0 и в (б) С2=0

А2=1
Умножим (4) на (6):

(С1∨В2)∧(А2∨Д4)=1
С1∧А2∨В2∧А2∨С1∧Д4∨В2∧Д4=1
Т. к. В2∧А2=0 (10), С1∧Д4=0 (Д4=0) и В2∧Д4=0 (Д4=0)
С1∧А2=1
С1=1, т. к. А2=1

Места:

  1. Саша
  2. Андрей


Решение задач путём построения графов

Пример1

При составлении расписания на пятницу были высказаны пожелания, чтобы информатика была первым или вторым уроком, физика — первым или третьим, история — вторым или третьим.
Можно ли удовлетворить одновременно все высказанные пожелания?

Решение

В соответствии с условием задачи, при помощи графов получается следующая схема:

Теперь нужно избавиться от лишних, противоречащих самим себе или условию, вариантов, зачеркнув их

  • В первом варианте первой ветки Ф1 противоречит Ин1 - вычёркиваем
  • Во втором варианте Ис3 противоречит Ф3 - вычёркиваем
  • В 1ом варианте второй ветки Ис3 также противоречит Ф3, а Ис2 - Ин2 - убираем
  • Во 2ом варианте второй ветки Ис2 противоречит Ин2 - убираем

В этой задаче есть два варианта ответа:

1 ур. | 2 ур. | 3 ур.
Информатика | История | Физика
Физика | Информатика | История

Пример2*

Для длительной международной экспедиции на околоземной космической станции надо из восьми претендентов отобрать шесть специалистов: по аэронавтике, космонавигации, биомеханике, энергетике, медицине и астрофизике. Условия полёта не позволяют совмещать работы по разным специальностям, хотя некоторые претенденты владеют двумя специальностями. Обязанности аэронавта могут выполнять Геррети и Нам; космонавигатора — Кларк и Фриш; биомеханика — Фриш и Нам; энергетика — Депардье и Леонов; врача — Депардье и Хорхес; астрофизика — Волков и Леонов.
По особенностям психологической совместимости врачи рекомендуют совместные полеты Фриша и Кларка, а также Леонова с Хорхесом и Депардье. Напротив, нежелательно, чтобы Депардье оказался в одной экспедиции с Намом, а Волков — с Кларком.
Кого следует включить в состав экспедиции?

Решение

Г - Геррети аэ - аэронавт
Н - Нам к - космонавигатор
К - Кларк б - биомеханик
Ф - Фриш э - энергетик
Д - Депардье в - врач
Х - Хорхес ас - астрофизик
В - Волков
Л - Леонов

Ответ:

Геррети - аэронавт
Фриш - космонавигатор
Нам - биомеханник
Леонов - энергетик
Хорхес - врач
Волков - астрофизик


Решение задач (самостоятельно)

Получение булева выражения по таблице истинности

Алгоритм

  1. Выбрать значение переменных, для которых значение функции равно 1

  2. Записать логическое умножение всех переменных для каждой стороки, где результат равен 1 (если значение переменных оавно 0, то берется ее отрицание)

  3. Логически сложить полученные выражения

  4. Упростить полученное выражение

Сатавьте булевы выражения по следующим таблицам истинности:

Задание 1

A | B | C | F
0 | 0 | 0 | 0
0 | 0 | 1 | 1
0 | 1 | 0 | 1
0 | 1 | 1 | 0
1 | 0 | 0 | 0
1 | 0 | 1 | 1
1 | 1 | 0 | 0
1 | 1 | 1 | 0

Задание 2

A | B | C | F
0 | 0 | 0 | 1
0 | 0 | 1 | 0
0 | 1 | 0 | 0
0 | 1 | 1 | 1
1 | 0 | 0 | 0
1 | 0 | 0 | 0
1 | 1 | 0 | 0
1 | 1 | 1 | 1


Примеры (готовимся к ЕГЭ)

Задача 1.

Какое из приведенных имен удовлетворяет логическому условию ¬ (первая буква гласная → вторая буква гласная) ∧ последняя буква гласная

  1. ИРИНА
  2. МАКСИМ
  3. АРТЕМ
  4. МАРИЯ

Решение

Способ 1.

Обозначим первое высказывание "Первая буква гласная" - А
"Вторая буква гласная" - В
"Последняя буква гласная" - С

Составим по условию задачи логическую формулу ¬(A→B)∧C;
Рассуждаем:
Высказывание С должно быть истинным, иначе в итоге получим ложь.
Импликация, записанная в скобках, должна быть ложной, в противном случае ее отрицание будет ложным.
Импликация ложна, если А - истина, а В - ложно.
Следовательно, первая буква - гласная, вторая буква - согласная, а последняя буква - гласная.

Ответ: Ирина.

Способ 2. Построим таблицу истинности данного логического выражения:

A | B | C | A→B | ¬(A→B) | ¬(A→B)∧C
0 | 0 | 0 | 1 | 0 | 0
0 | 0 | 1 | 1 | 0 | 0
0 | 1 | 0 | 1 | 0 | 0
1 | 0 | 0 | 0 | 1 | 0
1 | 1 | 0 | 1 | 0 | 0
1 | 0 | 1 | 0 | 1 | 1
0 | 1 | 1 | 1 | 0 | 0
1 | 1 | 1 | 1 | 0 | 0

Ответ: Ирина.

Пример 2.

Какое логическое выражение равносильно выражению ¬ (¬A ∨¬B) ∧ C

  1. ¬A ∨B ∨ ¬C
  2. A ∧ B ∧ C
  3. (A ∨B)∧ C
  4. (¬A ∧ ¬B) ∨¬C

Решение:

Используя закон де Моргана, упростим данное логическое выражение:

¬ (¬A ∨¬B) ∧ C = A ∧ B ∧ C

Ответ: 2

Пример 3.

Дан фрагмент таблицы истинности выражения F:
X | Y | Z | F
1 | 1 | 1 | 1
1 | 1 | 0 | 1
1 | 0 | 1 | 1

Каким выражением может быть F?

  1. X ∧ Y ∧ Z
  2. ¬X ∨ ¬Y ∨ Z
  3. X ∨Y ∨ Z
  4. X ∧Y ∧¬Z

Решение:

Проверим 1 выражение: 1) 1 ∧ 1 ∧ 1 = 1; 2)1 ∧ 1 ∧ 0 = 0;
Первое выражение не может быть F.
Проверим 2 выражение:2) ¬1 ∨ ¬1 ∨1 = 1; 2) ¬1 ∨ ¬1 ∨0 = 0;
Второе выражение не может быть F.
Проверим 3 выражение: 1) 1 ∨1 ∨ 1 = 1; 2)1 ∨1 ∨ 0 = 1; 3) 1 ∨ 0 ∨ 1 = 1;
Третье выражение может быть F.

Ответ: 3

Пример4.

Сколько различных решений имеет уравнение
(K v L v M) ∧ (¬L ∧¬M ∧ N) = 1,
где K, L, M, N – логические переменные?

Решение.

Высказывание (K v L v M) ∧ (¬L ∧ ¬M ∧ N) истинно только в том случае, когда истинны оба высказывания (K v L v M) и (¬L 7and; ¬M ∧ N).

Второе из этих высказываний, (¬L ∧ ¬M ∧ N), истинно только при L = 0, M = 0, N = 1.

При найденных значениях L и M первое высказывание, (K v L v M), истинно, если K = 1.

Ответ: Уравнение имеет только одно решение

Пример 5.

В таблице приведены запросы к поисковому серверу. Расположите обозначения запросов в порядке возрастания количества страниц, которые найдёт поисковый сервер по каждому запросу. Для обозначения логической операции “ИЛИ” в запросе используется символ I, а для логической операции “И” – символ &.

А Законы & Физика
Б Законы I (Физика & Биология)
В Законы & Физика & Биология & Химия
Г Законы I Физика I Биология

Решение:

Первый способ основан на рассуждении.

Рассуждая логически, мы видим, что больше всего будет найдено страниц по запросу Г, так как при его исполнении будут найдены и страницы со словом “законы”, и страницы, со словом “физика”, и страницы со словом “биология”.

Меньше всего будет найдено страниц по запросу В, так как в нем присутствие всех четырех слов на искомой странице.

Осталось сравнить запросы А и Б. По запросу Б будут найдены все страницы, соответствующие запросу А, (так как в последних обязательно присутствует слово “законы”), а также страницы, содержащие одновременно слова “физика” и “биология”.
Следовательно по запросу Б будет найдено больше страниц, чем по запросу А.

Итак, упорядочив запросы по возрастанию страниц, получаем ВАБГ.

Ответ: ВАБГ.

Пример 6.

Ниже в табличной форме представлен фрагмент базы данных о результатах тестирования учащихся (используется стобальная шкала)
Фамилия | Пол | Математика | Русский язык | Химия | Информатика | Биология
Аганян | ж | 82 | 56 | 46 | 32 | 70
Воронин | м | 43 | 62 | 45 | 74 | 23
Григорчук | м | 54 | 74 | 68 | 75 | 83
Роднина | ж | 71 | 63 | 56 | 82 | 79
Сергеенко | ж | 33 | 25 | 74 | 38 | 46
Черепанова | ж | 18 | 92 | 73 | 28 | 61

Сколько записей в данном фрагменте удовлетворяют условию
“Пол=’м’ ИЛИ Химия>Биология”?

  1. 5
  2. 2
  3. 3
  4. 4

Решение:

Выбираем записи: Мальчики (двое) и Химия>Биология (трое, но один мальчик, уже взялся 1 раз). В итоге 4 записи удовлетворяют условию.

Ответ: 4

Пример 7.

В школьном первенстве по настольному теннису в четверку лучших вошли девушки: Наташа, Маша, Люда и Рита.
Самые горячие болельщики высказали свои предположения о распределении мест в дальнейших состязаниях.
Один считает, что первой будет Наташа, а Маша будет второй.
Другой болельщик на второе место прочит Люду, а Рита, по его мнению, займет четвертое место.
Третий любитель тенниса с ними не согласился. Он считает, что Рита займет третье место, а Наташа будет второй.
Когда соревнования закончились, оказалось, что каждый из болельщиков был прав только в одном из своих прогнозов.
Какое место на чемпионате заняли Наташа, Маша, Люда, Рита?
(В ответе перечислите подряд без пробелов числа, соответствующие местам девочек в указанном порядке имен.)

Решение:

Обозначим высказывания:
Н1 = “первой будет Наташа”;
М2 = “второй будет Маша”;
Л2 = “второй будет Люда”;
Р4 = “четвертой будет Рита”;
Р3 = “третьей будет Рита”;
Н2 = “второй будет Наташа”.

Согласно условию:
из высказываний 1 болельщика следует, что Н1VМ2 истинно;
из высказываний2 болельщика следует, что Л2VР4 истинно;
из высказываний 3 болельщика следует, что Р3VН2 истинно.
Следовательно, истинна и конъюнкция

(Н1VМ2) /\ (Л2VР4) /\ (Р3VН2) = 1.
Раскрыв скобки получим:
(Н1VМ2) /\ (Л2VР4) /\ (Р3VН2) = (Н1/\Л2V Н1/\Р4 V М2/\Л2 V М2/\Р4) /\ (Р3VН2)= Н1/\ Л2/\Р3 V Н1/\Р4/\Р3 V М2/\Л2/\Р3 V М2/\Р4/\Р3 V Н1/\Л2/\Н2 V Н1/\Р4/\Н2 V М2/\Л2/\Н2 V М2/\Р4/\Н2
=Н1/\ Л2/\Р3 V 0 V 0 V 0 V 0 V 0 V 0 V= Н1/\ Л2/\Р3
Наташа-1, Люда-2, Рита-3, а Маша-4.

Ответ: 1423

Пример 8*

Сколько существует различных наборов значений логических переменных x1, x2, ... x9, x10, которые удовлетворяют всем перечисленным ниже условиям?

((x1 ≡ x2) \/ (x3 ≡ x4)) /\ (¬(x1 ≡ x2) \/ ¬(x3 ≡ x4)) =1
((x3 ≡ x4) \/ (x5 ≡ x6)) /\ (¬(x3 ≡ x4) \/ ¬(x5 ≡ x6)) =1
((x5≡ x6) \/ (x7 ≡ x8)) /\ (¬(x5 ≡ x6) \/ ¬(x7 ≡ x8)) =1
((x7 ≡ x8) \/ (x9 ≡ x10)) /\ (¬(x7 ≡ x8) \/ ¬(x9 ≡ x10)) =1

В ответе не нужно перечислять все различные наборы значений x1, x2, ... x9, x10, при которых выполнена данная система равенств. В качестве ответа вам нужно указать количество таких наборов

Решение:

Проведем замену:

(x1 ≡ x2)=y1

(x3 ≡ x4)=y2

(x5 ≡ x6)=y3

(x7 ≡ x8)=y4

(x9 ≡ x10)=y5

Перепишем систему уравнений с учетом замены:

(y1Vy2)≡(¬y1V¬y2)=1

(y2Vy3)≡(¬y2V¬y3)=1

....

(y4Vy5)≡(¬y4V¬y5)=1

Решим первое уравнение (y1Vy2)≡(¬y1V¬y2)=1.Преобразуем логическое выражение (y1Vy2)≡(¬y1V¬y2):

(y1Vy2)≡(¬y1V¬y2)=(y1≡¬y1)V(y1?¬y2)V(y2≡¬y1)V(y2≡¬y2)=0V(y1≡¬y2)V(y2≡¬y1)V0=(y1≡¬y2)V(y2≡¬y1).

Отобразим логическое выражение (y1≡¬y2)V(y2≡¬y1) с помощью диаграммы Эйлера-Венна:

Видно по рисунку,что это инверсия эквиваленции: ¬(y1 ≡y2) или ¬(y1 ↔ y2).

Перепишем уравнение: ¬(y1 ↔y2)=1. Отсюда (y1 ↔ y2)=0. Такое уравнение имеет 2 решения:y1=1,y2=0 или y1=0,y2=1.

Рассмотрим 2-ое уравнение. С учетом преобразований оно становится таким:¬(y2≡y3)=1.

Решим систему из двух уравнений:

¬(y1≡y2)=1

¬(y2≡y3)=1

Перепишем систему в одно уравнение:¬(y1≡y2)≡¬(y2≡y3)=1.

Преобразуем ¬(y1≡y2)≡¬(y2≡y3):

¬(y1≡y2)≡¬(y2≡y3)=¬( (y1≡y2)V(y2≡y3) )-выносим отрицание за скобки.

Уравнение примет вид:¬( (y1≡y2)V(y2≡y3) )=1. Отсюда (y1≡y2)V(y2?y3)=0.

Логическое выражение выполняется, только когда (y1≡y2)=0 и (y2≡y3)=0.

Пусть y2=0.

y1≡0=0-выполняется при y1=1.

0?y3=0-выполняется при y3=1.

Получаем одно решение:y2=0,y1=1,y3=1.

Пусть y2=1.

y1≡1=0-выполняется при y1=0.

0≡y3=0-выполняется при y3=0.

Получаем одно решение:y2=1,y1=0,y3=0.

Общее число решений при двух уравнениях системы:1+1=2 решения.

Таким образом,при добавлении одного уравнения к самому первому уравнению не меняется число решений, остается равным двум. Следовательно, добавление остальных уравнений не изменит общее количество решений. Остается два решения.

Теперь перейдем к поиску количества решений, используя обратную подстановку для y.

y1=(x1 ≡ x2)-для каждого из значений y1 есть два решения. Например,если y=0,то x1=0,x2=1 или x1=1,x2=0.

y2=(x3 ≡ x4)-для каждого из значений y2 есть два решения.

Аналогично и для остальных:y3,y4,y5. Пары решений (x1,x2),(x3,x4),(x5,x6),(x7,x8),(x9,x10) - не зависят друг от друга, поэтому комбинаций решений равно 25=32.(основание равно 2,т.к. каждая пара дает два решения, а степень равна 5,т.к. у нас есть 5 пар).

В данном случае мы не учли, что и y1,y2,y3,y4,y5 дают нам в два раза больше решений.

Ответ: Общее количество решений:32*2=64 решения.


Решить самостоятельно

Пример 1.

На новогодний праздник три друга – Евгений, Николай, Алексей, выбрали себе костюмы трех богатырей: Ильи Муромца, Алеши Попович, Добрыни Никитича. Известно, что: Евгений – самый высокий Выбравший костюм Добрыни Никитича меньше ростом, чем выбравший костюм Ильи Муромца Алексею не подошел костюм Добрыни Никитича Ни у одного из друзей имена не совпадает с именем богатырей, выбранных костюмов Какой костюм выбрал каждый из друзей?

Ответ:

Алексей - Илья Муромец, Николай - Добрыня Никитич, а Евгений - Алеша Попович. ложно. Какое место на соревнованиях занял каждый из юношей, если все они заняли разные места.

Пример 2.

Алеша, Илья и Добрыня нашли в земле хорошо сохранившийся стеклянный сосуд с житкостью. Рассматривая удивительную находку, каждый высказал по два предположения:
Алеша: «Это сосуд французский и имеет 5 звездочек».
Илья: «Это сосуд испанский и имеет 3 звездочки».
Добрыня: «Это сосуд не французский и имеет 4 звездочки»
Змей Горыныч доходчиво объяснил ребятам, что каждый из них прав только в одном из двух предположений.
Где изготовлен и во сколько звездочек оченивается его качество?

Пример 3.

На столе лежат в ряд фигуры: треугольник, ромб, круг и квадрат.
Цвета этих фигур - зеленый, черный, синий, красный
Фигура красного цвета лежит между зеленой и синей, справа от черной фигуры лежит ромб, круг лежит правее треугольника и ромба, и, наконец, фигура синего цвета не лежит рядом с фигурой черного.
Какого цвета круг?

Пример 4.

Борису, Ивану и Сергею предъявлено обвинение в соучастии в ограблении сбербанка.
В ходе следствия Борис сказал, что преступники были на синем «Запорожце»,
Иван сказал, что это был черный «Москвич»,
Сергей утверждал, что это была «Ока», но не синяя.
Каждый указал неправильно либо марку, либо цвет автомобиля.
Определите цвет и марку.

Пример5.

Перед вами 5 коробочек: белая, черная, красная, синяя и зеленая.
Так же есть по 2 шарика каждого из цветов.
В каждой коробочке лежит по 2 шарика.
Известно, что:
  • ни один шарик не лежит в коробочке того же цвета, что и он сам;
  • в красной коробочке нет синих шариков;
  • в каробочке нейтрального(черной или белой) лежит один красный и один зеленый шарик;
  • в черной коробочке лежат шарики холодных тонов(синий и зеленый);
  • в одной из коробочек лежат один белый и один синий шарик;
  • в синей коробочке находится один черный шарик
Вопрос: какого цвета шарики лежат в каждой из коробочек?

Пример 6.

На соревнованиях по боулингу Андрей, Борис, Сергей и Володя заняли первые четыре места. Но когда девушки стали вспоминать, как эти места распределились между победителями, то мнения разошлись.
Даша сказала: «Андрей был первым, а Володя - вторым».
Галя утверждала: «Андрей был вторым, а Борис - третьим»
. Лена считала: «Борис был четвертым, а Сергей - вторым»
. Аня. которая была судьей на этих соревнованиях и хорошо помнила, как распределились места, сказала, что каждая из девушек сделала одно правильное и одно неправильное заявление.
Какой из юношей занял какое место?

Ответы к задачам 2-6

  1. Этот сосуд испанский и оценивается в 3 звезды.
  2. Круг синий
  3. Преступники были на черном «Запорожце».
  4. в белой коробочке - красный и зеленый шарик, в черной - синий и зеленый, в красной - белый и черный, в синей - белый и красный, в зеленой - черный и синий.
  5. 1 место - Андрей, 2 место - Сергей, 3 место - Борис, 4 место - Володя.


Как решать задачи с помощью диаграмм Эйлера-Венна

Некоторые задачи удобно и наглядно решать с помощью диаграмм Эйлера-Венна. Например, задачи на множества.

Задача 1.

В школе с углубленным изучением иностранных языков провели опрос среди 100 учащихся. Ученикам задали вопрос: "Какие иностранные языки вы изучаете?". Выяснилось, что 48 учеников изучают английский, 26 - французский, 28 - немецкий. 8 школьников изучают английский и немецкий, 8 - английский и французский, 13 - французский и немецкий. 24 школьника не изучают ни английский, ни французский, ни немецкий. Сколько школьников, прошедших опрос, изучают одновременно три языка: английский, французский и немецкий?

Ответ: 3.

Решение:

Сначала определим множества и введем обозначения. Их три:

  • множество школьников, изучающих английский ("А");
  • множество школьников изучающих французский ("Ф");
  • множество школьников изучающих немецкий ("Н").

Изобразим с помощью диаграммы Эйлера-Венна то, что нам дано по условию.

Решение задач с помощью диаграмм Эйлера-Венна, задача 1

Изобразим то, что нам надо найти:

Решение задач с помощью диаграмм Эйлера-Венна, задача 1,найти

Определим количество школьников для всех возможных областей.

Обозначим искомую область А=1, Ф=1, Н=1 как "х" (в таблице ниже область №7). Выразим остальные области через х.

0) Область А=0, Ф=0, Н=0: 24 школьника - дано по условию задачи.

1) Область А=0, Ф=0, Н=1: 28-(8-х+х+13-х)=7+х школьников.

2) Область А=0, Ф=1, Н=0: 26-(8-х+х+13-х)=5+х школьников.

3) Область А=0, Ф=1, Н=1: 13-х школьников.

4) Область А=1, Ф=0, Н=0: 48-(8-х+х+8-х)=32+х школьников.

5) Область А=1, Ф=0, Н=1: 8-х школьников.

6) Область А=1, Ф=1, Н=0: 8-х школьников.

Запишем значения областей в таблицу:

№ области | А | Ф | Н | Количество школьников
0 | 0 | 0 | 0 | 24
1 | 0 | 0 | 1 | 7+х
2 | 0 | 1 | 0 | 5+х
3 | 0 | 1 | 1 | 13-х
4 | 1 | 0 | 0 | 32+х
5 | 1 | 0 | 1 | 8-х
6 | 1 | 1 | 0 | 8-х
7 | 1 | 1 | 1 | х

Изобразим значения для всех областей с помощью диаграммы:

Решение задач с помощью диаграмм Эйлера-Венна, задача 1, решение

Определим х:

24+7+(х+5)+х+(13-х)+(32+х)+(8-х)+(8-х)+х=100.

х=100-(24+7+5+13+32+8+8)=100-97=3.

Получили, что 3 школьника изучают одновременно три языка: английский, французский и немецкий.

Так будет выглядеть диаграмма Эйлера-Венна при известном х:

Решение задач с помощью диаграмм Эйлера-Венна, задача 1, ответ

Решить самостоятельно

Задача 1

На олимпиаде по математике школьникам предложили решить три задачи: одну по алгебре, одну по геометрии, одну по тригонометрии. В олимпиаде участвовало 1000 школьников. Результаты олимпиады были следующие: задачу по алгебре решили 800 участников, по геометрии - 700, по тригонометрии - 600. 600 школьников решили задачи по алгебре и геометрии, 500 - по алгебре и тригонометрии, 400 - по геометрии и тригонометрии. 300 человек решили задачи по алгебре, геометрии и тригонометрии. Сколько школьников не решило ни одной задачи?

Ответ: 100

Задача 2

На олимпиаде по физике школьникам предложили решить три задачи: одну по кинематике, одну по термодинамике, одну по оптике. Результаты олимпиады были следующие: задачу по кинематике решили 400 участников, по термодинамике - 350, по оптике - 300. 300 школьников решили задачи по кинематике и термодинамике, 200 - по кинематике и оптике, 150 - по термодинамике и оптике. 100 человек решили задачи по кинематике, термодинамике и оптике. Сколько школьников решило две задачи?

Ответ: 350.

Желяю удачи!


Логические элементы ПК

Как же использовать полученные нами знания из области математической логики для конструирования электронных устройств?

Нам известно, что О и 1 в логике не просто цифры, а обозначение состояний какого-то предмета нашего мира, условно называемых "ложь" и "истина". Таким предметом, имеющим два фиксированных состояния, может быть электрический ток.

Устройства, фиксирующие два устойчивых состояния, называются бистабильными (например, выключатель, реле).

Если вы помните, первые вычислительные машины были релейными. Позднее были созданы новые устройства управления электричеством - электронные схемы, состоящие из набора полупроводниковых элементов. Такие электронные схемы, которые преобразовывают сигналы только двух фиксированных напряжений электрического тока (бистабильные) , стали называть логическими элементами.

Логический элемент компьютера — это часть электронной логичеcкой схемы, которая реализует элементарную логическую функцию

Логическими элементами компьютеров являются электронные схемы И, ИЛИ, НЕ, И-НЕ, ИЛИ-НЕ и другие (называемые также вентилями), а также триггер.

С помощью этих схем можно реализовать любую логическую функцию, описывающую работу устройств компьютера. Обычно у вентилей бывает от двух до восьми входов и один или два выхода.

Чтобы представить два логических состояния — “1” и “0” в вентилях, соответствующие им входные и выходные сигналы имеют один из двух установленных уровней напряжения. Например, +5 вольт и 0 вольт.

Высокий уровень обычно соответствует значению “истина” (“1”), а низкий — значению “ложь” (“0”).

Каждый логический элемент имеет свое условное обозначение, которое выражает его логическую функцию, но не указывает на то, какая именно электронная схема в нем реализована. Это упрощает запись и понимание сложных логических схем.

Работу логических элементов описывают с помощью таблиц истинности.

Таблица истинности это табличное представление логической схемы (операции), в котором перечислены все возможные сочетания значений истинности входных сигналов (операндов) вместе со значением истинности выходного сигнала (результата операции) для каждого из этих сочетаний.

Логические (функциональные) схемы

Логические схемы
Таблицы истинности
Схема "И"

X | Y | X ∧Y
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1
Схема "ИЛИ"

X | Y | X ∨Y
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1
Схема "НЕ"

X | ¬X
0 | 1
1 | 0
Схема "И - НЕ"

X | Y | ¬(X ∧Y)
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 0
Схема "ИЛИ - НЕ"

X | Y | ¬(X ∨Y)
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 0


Логические элементы ПК

Как же использовать полученные нами знания из области математической логики для конструирования электронных устройств?

bxdhgcjfhgcj


Какой сигнал получится на выходе схемы (в точке E)

Решение задач

Карточка № 1 Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0001

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0002

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0003

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0004

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0005

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0006

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0007

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0008

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0009

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0010

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0011

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0012

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0013

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0014

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0015

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |

Какой сигнал получится на выходе схемы (в точке E)

Если сигналы, подаваемые из точек A, B, C, D будут иметь следующие значения.

L 0016

№ | A | B | C | D | E
1 | 0 | 0 | 0 | 0 |
2 | 0 | 0 | 0 | 1 |
3 | 0 | 0 | 1 | 0 |
4 | 0 | 0 | 1 | 1 |
5 | 0 | 1 | 0 | 0 |
6 | 0 | 1 | 0 | 1 |
7 | 0 | 1 | 1 | 0 |
8 | 0 | 1 | 1 | 1 |
9 | 1 | 0 | 0 | 0 |
10 | 1 | 0 | 0 | 1 |
11 | 1 | 0 | 1 | 0 |
12 | 1 | 0 | 1 | 1 |
13 | 1 | 1 | 0 | 0 |
14 | 1 | 1 | 0 | 1 |
15 | 1 | 1 | 1 | 0 |
16 | 1 | 1 | 1 | 1 |


Памятки


Самостоятельная работа. Вариант 1.

Словарь терминов

Название | Обозначение
Инверсия (отрицание) | ,не
Дизъюнкция (логическое сложение) | , OR, или
Конъюнкция (логическое умножение) | , [image] , and, и
Импликация | , если ..., то
Эквивалентность | , тогда и только тогда


Проверочная работа

«Тест по теме "Основы логики"

Вопрос 1. Для какого числа Х истинно высказывание: (Х > 1) ∧ ((Х < 5) -> (Х < 3))

Ответ 1. 1
Ответ 2. 2
Ответ 3. 3
Ответ 4. 4

Вопрос 2. Для какого числа Х истинно высказывание: (Х > 4) ∨((Х > 1) -> (Х > 4))

Ответ 1. 1
Ответ 2. 2
Ответ 3. 3
Ответ 4. 4

Вопрос 3. Для какого числа Х истинно высказывание: ((Х > 3) v (Х < 3)) -> (Х < 1)

Ответ 1. 1
Ответ 2. 2
Ответ 3. 3
Ответ 4. 4

Вопрос 4. Какое логическое выражение равносильно выражению: ¬ (А ^ В) ^ ¬ С

Ответ 1. ¬ A v В v ¬ С
Ответ 2. (¬ А ∨ ¬ В) ∧¬ С
Ответ 3. (¬ А ∨¬ В) ∧С
Ответ 4. ¬ А ^ ¬ В ^ ¬ С

Вопрос 5. Для какого имени истинно высказывание: ¬ (Первая буква имени гласная -> Четвертая буква имени согласная)

Ответ 1. ЕЛЕНА
Ответ 2. ВАДИМ
Ответ 3. АНТОН
Ответ 4. ФЕДОР

Вопрос 6. Какое логическое выражение равносильно выражению: ¬ (A v ¬ B)

Ответ 1. A v B
Ответ 2. А ^ В
Ответ 3. ¬ A v ¬ B
Ответ 4. ¬ А ^ В

Вопрос 7. Какое логическое выражение равносильно выражению: ¬ (¬ А ^ В)

Ответ 1. A v ¬ В
Ответ 2. ¬ A v В
Ответ 3. В ^ ¬ А
Ответ 4. А ^ ¬ В

Вопрос 8. Какое логическое выражение равносильно выражению: ¬ (¬ А v В) v ¬ С

Ответ 1. (А ^ ¬ В) v ¬ С
Ответ 2. ¬ A v В v ¬ С
Ответ 3. A v ¬ В v ¬ С
Ответ 4. (¬ А ^ В) v ¬ С

Вопрос 9. Дан фрагмент таблицы истинности выражения F. Какое выражение соответствует F?

Ответ 1. ¬ X v ¬ Y v ¬ Z
Ответ 2. X ^ ¬ Y ^ ¬ Z
Ответ 3. X v Y v Z
Ответ 4. X ^ Y ^ Z

Вопрос 10. Дан фрагмент таблицы истинности выражения F. Какое выражение соответствует F?

Ответ 1. ¬ X v Y v ¬ Z
Ответ 2. X ^ Y ^ ¬ Z
Ответ 3. ¬ X ^ ¬ Y ^ Z
Ответ 4. X v ¬Y v Z

Вопрос 11. Дан фрагмент таблицы истинности выражения F. Какое выражение соответствует F?

Ответ 1. X ^ Y ^ Z
Ответ 2. ¬ X v ¬ Y v Z
Ответ 3. X ^ Y ^ ¬ Z
Ответ 4. ¬ X ^ ¬ Y ^ ¬ Z

Вопрос 12. Дан фрагмент таблицы истинности выражения F. Какое выражение соответствует F?

Ответ 1. ¬ X ^ ¬ Y ^ Z
Ответ 2. ¬ X v ¬Y v Z
Ответ 3. X v Y v ¬ Z
Ответ 4. X v Y v Z

Вопрос 13. Укажите значения переменных K, L, M, N, при которых логическое выражение (¬ К v M)->( ¬ L v M v N) ложно. Ответ запишите в виде строки из четырех символов - значений переменных K, L, M и N (в указанном порядке).

Ответ 1. 0101
Ответ 2. 0100
Ответ 3. 1011
Ответ 4. 1100

Вопрос 14. Сколько различных решений имеет уравнение (K ^ L ^ M) v (¬ L ^ ¬ M ^ N) = 1, где - K, L, M, N логические переменные?

Ответ 1. 1
Ответ 2. 2
Ответ 3. 3
Ответ 4. 4


Учебник

Уроки по логике

Электронное пособие по информатике. Автор Струкова Н.Ф. учитель информатики, МБОУ СОШ № 13, Златоуст


Как решать задачи с помощью диаграмм Эйлера-Венна

INFOEGEHELP.RU

Успешно сдать ЕГЭ по информатике
  • Главная
  • Контакты
  • Карта сайта
  • Помощь сайту
Важно
  • Учим числа: 2 в степени
  • Биты, байты, килобайты и т.п.
ЕГЭ по информатике: решение задач
  • Быстрый поиск задачи из демо ЕГЭ 2012,2011,2010,2009
  • -----------------------------------------------
  • Задачи,не рассмотренные в основных разделах информатики
Разделы информатики
  • 2011-12-18-14-33-54 Системы счисления
  • -----------------------------------------------
  • 2011-12-18-16-45-20 Алгебра логики
  • -----------------------------------------------
  • 2011-12-18-16-55-26 Програм мирование
  • -----------------------------------------------
  • 2011-12-18-16-53-40 Кодирование информации
  • -----------------------------------------------
  • 2011-12-18-16-56-19 Компьютерные сети и Интернет
  • -----------------------------------------------
  • -excel Электронные таблицы (Excel)
  • -----------------------------------------------
  • 2011-12-18-16-57-50 Базы данных
  • -----------------------------------------------
  • 2011-12-18-16-58-50 Графы
  • -----------------------------------------------
  • 2011-12-18-17-00-15 Файловая система
Алгебра логики [image] Как решать задачи с помощью диаграмм Эйлера-Венна

Как решать задачи с помощью диаграмм Эйлера-Венна

Некоторые задачи удобно и наглядно решать с помощью диаграмм Эйлера-Венна. Например, задачи на множества. Если Вы не знаете, что такое диаграммы Эйлера-Венна и как их строить, то сначала прочтите эту статью.

Теперь разберем типовые задачи о множествах.

Задача 1.

В школе с углубленным изучением иностранных языков провели опрос среди 100 учащихся. Ученикам задали вопрос: "Какие иностранные языки вы изучаете?". Выяснилось, что 48 учеников изучают английский, 26 - французский, 28 - немецкий. 8 школьников изучают английский и немецкий, 8 - английский и французский, 13 - французский и немецкий. 24 школьника не изучают ни английский, ни французский, ни немецкий. Сколько школьников, прошедших опрос, изучают одновременно три языка: английский, французский и немецкий?

Ответ: 3.

Решение:

Сначала определим множества и введем обозначения. Их три:

  • множество школьников, изучающих английский ("А");
  • множество школьников изучающих французский ("Ф");
  • множество школьников изучающих немецкий ("Н").

Изобразим с помощью диаграммы Эйлера-Венна то, что нам дано по условию.

Решение задач с помощью диаграмм Эйлера-Венна, задача 1

Изобразим то, что нам надо найти:

Решение задач с помощью диаграмм Эйлера-Венна, задача 1,найти

Определим количество школьников для всех возможных областей.

Обозначим искомую область А=1, Ф=1, Н=1 как "х" (в таблице ниже область №7). Выразим остальные области через х.

0) Область А=0, Ф=0, Н=0: 24 школьника - дано по условию задачи.

1) Область А=0, Ф=0, Н=1: 28-(8-х+х+13-х)=7+х школьников.

2) Область А=0, Ф=1, Н=0: 26-(8-х+х+13-х)=5+х школьников.

3) Область А=0, Ф=1, Н=1: 13-х школьников.

4) Область А=1, Ф=0, Н=0: 48-(8-х+х+8-х)=32+х школьников.

5) Область А=1, Ф=0, Н=1: 8-х школьников.

6) Область А=1, Ф=1, Н=0: 8-х школьников.

Запишем значения областей в таблицу:

№ области | А | Ф | Н | Количество школьников
0 | 0 | 0 | 0 | 24
1 | 0 | 0 | 1 | 7+х
2 | 0 | 1 | 0 | 5+х
3 | 0 | 1 | 1 | 13-х
4 | 1 | 0 | 0 | 32+х
5 | 1 | 0 | 1 | 8-х
6 | 1 | 1 | 0 | 8-х
7 | 1 | 1 | 1 | х

Изобразим значения для всех областей с помощью диаграммы:

Решение задач с помощью диаграмм Эйлера-Венна, задача 1, решение

Определим х:

24+7+(х+5)+х+(13-х)+(32+х)+(8-х)+(8-х)+х=100.

х=100-(24+7+5+13+32+8+8)=100-97=3.

Получили, что 3 школьника изучают одновременно три языка: английский, французский и немецкий.

Так будет выглядеть диаграмма Эйлера-Венна при известном х:

Решение задач с помощью диаграмм Эйлера-Венна, задача 1, ответ

Задача 2.

На олимпиаде по математике школьникам предложили решить три задачи: одну по алгебре, одну по геометрии, одну по тригонометрии. В олимпиаде участвовало 1000 школьников. Результаты олимпиады были следующие: задачу по алгебре решили 800 участников, по геометрии - 700, по тригонометрии - 600. 600 школьников решили задачи по алгебре и геометрии, 500 - по алгебре и тригонометрии, 400 - по геометрии и тригонометрии. 300 человек решили задачи по алгебре, геометрии и тригонометрии. Сколько школьников не решило ни одной задачи?

Ответ: 100.

Решение:

Сначала определим множества и введем обозначения. Их три:

  • множество задач по алгебре ("А");
  • множество задач по геометрии ("Г");
  • множество задач по тригонометрии ("Т").

Изобразим с помощью диаграммы Эйлера-Венна то, что нам дано по условию:

Решение задач с помощью диаграмм Эйлера-Венна, задача 2

Изобразим то, что нам надо найти:

Решение задач с помощью диаграмм Эйлера-Венна, задача 2, найти

Определим количество школьников для всех возможных областей.

Обозначим искомую область А=0, Г=0, Т=0 как "х" (в таблице ниже область №0).

Найдем остальные области:

1) Область А=0, Г=0, Т=1: школьников нет.

2) Область А=0, Г=1, Т=0: школьников нет.

3) Область А=0, Г=1, Т=1: 100 школьников.

4) Область А=1, Г=0, Т=0: школьников нет.

5) Область А=1, Г=0, Т=1: 200 школьников.

6) Область А=1, Г=1, Т=0: 300 школьников.

7) Область А=1, Г=1, Т=1: 300 школьников.

Запишем значения областей в таблицу:

№ области | А | Г | Т | Количество школьников
0 | 0 | 0 | 0 | х
1 | 0 | 0 | 1 | 0
2 | 0 | 1 | 0 | 0
3 | 0 | 1 | 1 | 100
4 | 1 | 0 | 0 | 0
5 | 1 | 0 | 1 | 200
6 | 1 | 1 | 0 | 300
7 | 1 | 1 | 1 | 300

Изобразим значения для всех областей с помощью диаграммы:

Решение задач с помощью диаграмм Эйлера-Венна, задача 2, решение

Определим х:

х=U-(A V Г V Т), где U-универсум.

U=1000.

A V Г V Т=0+0+0+300+300+200+100=900.

x=1000-900=100.

Получили, что 100 школьников не решило ни одной задачи.

Задача 3.

На олимпиаде по физике школьникам предложили решить три задачи: одну по кинематике, одну по термодинамике, одну по оптике. Результаты олимпиады были следующие: задачу по кинематике решили 400 участников, по термодинамике - 350, по оптике - 300. 300 школьников решили задачи по кинематике и термодинамике, 200 - по кинематике и оптике, 150 - по термодинамике и оптике. 100 человек решили задачи по кинематике, термодинамике и оптике. Сколько школьников решило две задачи?

Ответ: 350.

Решение:

Сначала определим множества и введем обозначения. Их три:

  • множество задач по кинематике ("К");
  • множество задач по термодинамике ("Т");
  • множество задач по оптике ("О").

Изобразим с помощью диаграммы Эйлера-Венна то, что нам дано по условию:

Решение задач с помощью диаграмм Эйлера-Венна, задача 3

Изобразим то, что нам надо найти:

Решение задач с помощью диаграмм Эйлера-Венна, задача 3, найти

Определим количество школьников для всех возможных областей:

0) Область К=0, Т=0, О=0: не определено.

1) Область К=0,Т=0, О=1: 50 школьников.

2) Область К=0, Т=1, О=0: школьников нет.

3) Область К=0, Т=1, О=1: 50 школьников.

4) Область К=1, Т=0, О=0: школьников нет.

5) Область К=1, Т=0, О=1: 100 школьников.

6) Область К=1, Т=1, О=0: 200 школьников.

7) Область К=1, Т=1, О=1: 100 школьников.

Запишем значения областей в таблицу:

№ области | К | Т | О | Количество школьников
0 | 0 | 0 | 0 | -
1 | 0 | 0 | 1 | 50
2 | 0 | 1 | 0 | 0
3 | 0 | 1 | 1 | 50
4 | 1 | 0 | 0 | 0
5 | 1 | 0 | 1 | 100
6 | 1 | 1 | 0 | 200
7 | 1 | 1 | 1 | 100

Изобразим значения для всех областей с помощью диаграммы:

Решение задач с помощью диаграмм Эйлера-Венна, задача 3, решение

Определим х.

х=200+100+50=350.

Получили, 350 школьников решило две задачи.

Задача 4.

Среди прохожих провели опрос. Был задан вопрос: "Какое домашнее животное у Вас есть?". По результатам опроса выяснилось, что у 150 человек есть кошка, у 130 - собака, у 50 - птичка. У 60 человек есть кошка и собака, у 20 - кошка и птичка, у 30 - собака и птичка. У 70 человек вообще нет домашнего животного. У 10 человек есть и кошка, и собака, и птичка. Сколько прохожих приняли участие в опросе?

Ответ: 300.

Решение:

Сначала определим множества и введем обозначения. Их три:

  • множество людей, у которых есть кошка ("К");
  • множество людей, у которых есть собака ("С");
  • множество людей, у которых есть птичка ("П").

Изобразим с помощью диаграммы Эйлера-Венна то, что нам дано по условию:

Решение задач с помощью диаграмм Эйлера-Венна, задача 4

Изобразим то, что нам надо найти:

Решение задач с помощью диаграмм Эйлера-Венна, задача 4, найти

Определим количество человек для всех возможных областей:

0) Область К=0, С=0, П=0: 70 человек.

1) Область К=0, С=0, П=1: 10 человек.

2) Область К=0, С=1, П=0: 50 человек.

3) Область К=0, С=1, П=1: 20 человек.

4) Область К=1, С=0, П=0: 80 человек.

5) Область К=1, Т=0, О=1: 10 человек.

6) Область К=1, Т=1, О=0: 50 человек.

7) Область К=1, Т=1, О=1: 10 человек.

Запишем значения областей в таблицу:

№ области | К | C | П | Количество человек
0 | 0 | 0 | 0 | 70
1 | 0 | 0 | 1 | 10
2 | 0 | 1 | 0 | 50
3 | 0 | 1 | 1 | 20
4 | 1 | 0 | 0 | 80
5 | 1 | 0 | 1 | 10
6 | 1 | 1 | 0 | 50
7 | 1 | 1 | 1 | 10

Изобразим значения для всех областей с помощью диаграммы:

Решение задач с помощью диаграмм Эйлера-Венна, задача 4, решение

Определим х:

х=U (универсум)

U=70+10+50+20+80+10+50+10=300.

Получили, что 300 человек приняли участие в опросе.

Задача 5.

На одну специальность в одном из ВУЗов поступало 120 человек. Абитуриенты сдавали три экзамена: по математике, по информатике и русскому языку. Математику сдали 60 человек, информатику - 40. 30 абитуриентов сдали математику и информатику, 30 - математику и русский язык, 25 - информатику и русский язык. 20 человек сдали все три экзамена, а 50 человек - провалили. Сколько абитуриентов сдали русский язык?

Ответ: 35.

Решение:

Сначала определим множества и введем обозначения. Их три:

  • множество абитуриентов, сдавших математику ("М");
  • множество абитуриентов, сдавших информатику ("И");
  • множество абитуриентов, сдавших русский язык ("Р");

Изобразим с помощью диаграммы Эйлера-Венна то, что нам дано по условию:

Решение задач с помощью диаграмм Эйлера-Венна, задача 5

Изобразим то, что нам надо найти:

Решение задач с помощью диаграмм Эйлера-Венна, задача 5, найти

Определим количество абитуриентов для всех возможных областей.

Обозначим искомую область как "х".

0) Область М=0, И=0, Р=0: 50 абитуриентов.

1) Область М=0, И=0, Р=1: х-35 абитуриентов.

2) Область М=0, И=1, Р=0: 5 абитуриентов.

3) Область М=0, И=1, Р=1: 20 абитуриентов.

4) Область М=1, И=0, Р=0: 80 абитуриентов.

5) Область М=1, И=0, Р=1: 10 абитуриентов.

6) Область М=1, И=1, Р=0: 50 абитуриентов.

7) Область М=1, И=1, Р=1: 10 абитуриентов.

Запишем значения областей в таблицу:

№ области | М | И | Р | Количество абитуриентов
0 | 0 | 0 | 0 | 50
1 | 0 | 0 | 1 | х-35
2 | 0 | 1 | 0 | 5
3 | 0 | 1 | 1 | 5
4 | 1 | 0 | 0 | 20
5 | 1 | 0 | 1 | 10
6 | 1 | 1 | 0 | 10
7 | 1 | 1 | 1 | 20

Изобразим значения для всех областей с помощью диаграммы:

Решение задач с помощью диаграмм Эйлера-Венна, задача 5, решение

Определим х:

х=120-50-(20+10+5)=35.

Получили, что 35 абитуриентов сдали русский язык.

Так будет выглядеть диаграмма Эйлера-Венна при известном х:

Решение задач с помощью диаграмм Эйлера-Венна, задача 5, ответ

Перейти к разбору задач на множества из демо ЕГЭ (определение количества страниц по запросу поискового сервера):

  • В12-2012
  • В9-2011
  • В10-2010
  • В10-2009

Перейти к другим задачам демо ЕГЭ.

Яндекс.Директ Все объявленияГазовый котел Navien Настенный газовый двухконтурный котел Navien Ace за 18000 руб. Покупайте! Адрес и телефон stroiset74.tiu.ru Отопление частного дома Безопасные и чистые системы отопления! Установка и обслуживание. Звоните! pellet74.ru Котлы газовые Продажа газовых котлов. Все поставщики в Челябинске! chel.pulscen.ru

© Латыпова В, 2012. Все права защищены.
Копирование материалов сайта только с разрешения администрации сайта